java.io.IOEXEPTION error when uploading

Hi,

New error started today - no updates or changes to Arduino/Java in past 24 hours. All previous codes which have successfully uploaded before no longer doing so, same error repeatedly. Have checked online for similar errors - nothing found with the “REMOVE” bit.

BN: Arduino/Genuino Uno
VID: 2A03
PID: 0043
SN: 85431303636351E092C0

Sketch uses 2,162 bytes (6%) of program storage space. Maximum is 32,256 bytes.
Global variables use 56 bytes (2%) of dynamic memory, leaving 1,992 bytes for local variables. Maximum is 2,048 bytes.
___REMOVE___/bin/avrdude -C___REMOVE___/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b115200 -D -Uflash:w:C:\Users\Haigh\AppData\Local\Temp\buildef2478b480a30c59a670d0abe6c616d2.tmp/servo.ino.hex:i 
java.io.IOException: Cannot run program "___REMOVE___/bin/avrdude": CreateProcess error=2, The system cannot find the file specified
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
	at processing.app.helpers.ProcessUtils.exec(ProcessUtils.java:26)
	at cc.arduino.packages.Uploader.executeUploadCommand(Uploader.java:130)
	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:209)
	at cc.arduino.UploaderUtils.upload(UploaderUtils.java:78)
	at processing.app.Sketch.upload(Sketch.java:1187)
	at processing.app.Sketch.exportApplet(Sketch.java:1160)
	at processing.app.Sketch.exportApplet(Sketch.java:1132)
	at processing.app.Editor$DefaultExportHandler.run(Editor.java:2409)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
	at java.lang.ProcessImpl.create(Native Method)
	at java.lang.ProcessImpl.<init>(ProcessImpl.java:386)
	at java.lang.ProcessImpl.start(ProcessImpl.java:137)
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
	... 9 more
An error occurred while uploading the sketch

Which version of the Arduino IDE are you using?

revamol: Have checked online for similar errors - nothing found with the "REMOVE" bit.

Actually there have been quite a few reports of this issue: https://www.google.com/search?q=""___REMOVE___/bin/avrdude"+site:http://forum.arduino.cc&domains=http://forum.arduino.cc&biw=2144&bih=1243&tbs=qdr:y&source=lnt&sa=X

Thank you. You are clearly better with search engines than myself.

If anyone stumbles on this in future:

Two hidden Windows folders:
C:/users/(your username)/AppData (hidden folder)/Local/Arduino15
C:/users/(your username)/AppData (hidden folder)/Roaming/Arduino15

Delete those folders and reinstall Arduino software.

Created an account to reply to this. I'm generally pretty good with Google but I was unable to find a solution for a while. deleting those two folders (did not have to reinstall Arduino) did it. Thank you.

For those who have issues finding the directories in windows explorer, you can use the following two commands:

rmdir /s %HOMEDRIVE%%HOMEPATH%\AppData\Local\Arduino15 rmdir /s %HOMEDRIVE%%HOMEPATH%\AppData\Roaming\Arduino15

Hello every body,

thanks a lot for the idea . it worked for me.

there is my setup - w7sp1 ARD IDE 1.8 ( the same problem happened with v1.6.12 installed earlier ) Ard Mega

the steps I have done are -

to close ARD IDE to locate folder c:\Users\admin\AppData\Local\Arduino15\ to delete it to start ARD IDE

it worked just fine after that. note : after ARD IDE restarted, folder c:\Users\admin\AppData\Local\Arduino15\ would be created again.

in my case I did not have to reinstall IDE

note: I was not able to locate folder C:/users/(your username)/AppData (hidden folder)/Roaming/Arduino15 on my system

thanks again with hope it will help somebody as it did to me.

Michael

more info in this thread, for mac users

http://forum.arduino.cc/index.php?topic=440213.new#new

For the record in Linux (Ubuntu) there is a hidden file in the root i.e. ".Arduino15" - delete it.

Thank you so much it post help me a lot!

Thank you again!