Je ne parient pas a faire fonctionner mon écran LCD avec I2c SUr arduino Mega

Bonjour
Je possède une arduino uno une arduino mega 2560 un écran QAPASS 16*2 et un module I2C qui étais déja soudé dessus lorsque je l’ai acheter sur Aliexpress
Je ne parvient pas a le faire fonctioner sur mon arduino Méga sur ma uno aucun probléme le scanner la trouve tout va bien c’est se code pour le scanner :

  #include <Wire.h>

void setup() {
  Serial.begin (9600);
  Serial.println ("I2C scanner. Scanning ...");
  byte count = 0;
  
  Wire.begin();
  for (byte i = 8; i < 120; i++)
  {
    Wire.beginTransmission (i);
    if (Wire.endTransmission () == 0)
      {
      Serial.print ("Found address: ");
      Serial.print (i, DEC);
      Serial.print (" (0x");
      Serial.print (i, HEX);
      Serial.println (")");
      count++;
      delay (1);  // maybe unneeded?
      } // end of good response
  } // end of for loop
  Serial.println ("Done.");
  Serial.print ("Found ");
  Serial.print (count, DEC);
  Serial.println (" device(s).");
}  // end of setup

void loop() {}

Voila et quand je fait les meme branchement sur ma carte Arduino mega les scanner ne trouve pas ma carte est ce que quelqu’un peu m’aidé s’il vous plait?

Pourquoi ta loop est vide ?
Shema ?

Ma loop est vide car le scanner ne scan qu'un seul fois la carte
et pour le shema ses GND sur GND VCC sur 5V SDA sur A5 SCL sur A4

ca serait pas
SDA=>A4
SCL=>A5

melvinlebailly:
Ma loop est vide car le scanner ne scan qu'un seul fois la carte
et pour le shema ses GND sur GND VCC sur 5V SDA sur A5 SCL sur A4

Bonjour,

Attention sur la mega, SDA et SCL ne sont pas sur A4 et A5. Il faut les connecter sur les pins SDA et SCL (ou pins 20 et 21 si ce n'est pas une mega R3).

Merci beaucoup kamill c'etait sa mon probleme maintenant mon scanere voit bien ma carte
Encore merci a tous pour vos reponse