LCD lights up but no text [solved]

Solved !


Gents,

I need some help.

I have a LCD display that was part of an Arduino starter kit. It shows 1602A on the back and I assume it is compatible with the LiquidCrystal library?

I basicaly tried to do the standard tutorial from

I also looked at this one: http://www.dreamdealer.nl/tutorials/connecting_a_1602a_lcd_display_and_a_light_sensor_to_arduino_uno.html

Code used:

// import libary
#include <LiquidCrystal.h>


// initialize the library by associating any needed LCD interface pin
// with the arduino pin number it is connected to
const int rs = 12, en = 11, d4 = 5, d5 = 4, d6 = 3, d7 = 2;
LiquidCrystal lcd(rs, en, d4, d5, d6, d7);

void setup() {
  // set up the LCD's number of columns and rows:
  lcd.begin(16, 2); 
  // Print a message to the LCD.
  lcd.print("hello, world!");
}

void loop() { }

It shows on the pictures that the display lights up and that it shows square characters on the first row. The pot meter works as well.

I simply cannot get any text to the display. I have wired according to the first URL tutorial. I have checked it multiple times.

Is it possible that I have broken something in the device due to wiring wrong previously?

I am pretty sure I downloaded the latest version of the library via the IDE. There is no need to copy any library files into the same folder as the code is there?

I have used multiple resistors.

I am using the arduino IDE and the mega 2560

Your help is much appreciated!

Hoi edwingerritsen, welkom op het Arduino forum !

Please edit your title and add [solved] to it, so people don't need to open this thread just to see they don't need to help any more and wasted time in doing so.

And please tell about your solution, because you might help someone else with that solution of yours.

I'd also like to point you to bperrybap's hd44780 library (click !), which can be installed through the IDE's library manager.
I'll be using that for all future projects using these sort of displays, because of all the advantages it offers.

Take a look at my signature below..

@edwingerritsen

Please go back to your original post and edit the subject which is what MAS3 really meant, for the reason he stated.

Don

Hi, have the same problem..
what was the solution????

Jawadakwar:
Hi, have the same problem…
what was the solution???

Attempting to ask someone who only ever came to this forum two years ago and not since is most unlikely to be productive. :roll_eyes:

And presuming your problem is in any way similar to his is also a bit of a stretch in any case.

Briefly speaking, if when you say “the same problem”, you mean you have a working backlight and a row of “blocks” on the top row, then the problem is that either your connections to pins 4 to 6 and 11 to 14 of the display are wrong, or your code is wrong.

The most common mistakes in that case are not having soldered the pin header to the display so that it is not actually connected, failing to connect pin 4 (“RW”) to ground, and having a faulty Chinese “Dupont” wire.

Should you answer and provide some information, we can help you further. :grinning: