Leonardo Ethernet Issue (IP always 0.47.47.47)

Good day,

I have purchased a Leonardo Eth without POE Arduino and I am having issues setting up the ethernet. I am referring to this one → http://www.arduino.org/products/boards/4-arduino-boards/arduino-leonardo-eth

I have tried to search the interwebs for anyone that has the same issue as I and I am not able to find anything.

I am using the webserver example but the IP address it allocates are completely different that what I set. It does not matter what I change it to, it stays at 0.47.47.47. I also had to remove the “server.begin” line code as it stops there without doing anything from there.

The code.

#include <SPI.h>
#include <Ethernet.h>
byte mac = {
0x90, 0xA2, 0xDA, 0x10, 0x37, 0xA9
};
IPAddress ip(192, 168, 1, 177);
EthernetServer server(80);
void setup() {
Serial.begin(9600);
while (!Serial) {
; // wait for serial port to connect. Needed for native USB port only
}
Serial.println(“Starting…”);
Ethernet.begin(mac, ip);
Serial.println(“Ethernet.Begin Complete”);
Serial.print("server is at ");
Serial.println(Ethernet.localIP());
}

The Output on serial:

Starting…
Ethernet.Begin Complete
server is at 0.173.173.173

If I put the following code between Ethernet.begin and Serial.println(Ethernet.localIP()), it never outputs “server.begin Complete”. I have put in delays for 4 seconds between each step and it does not resolve the issue.

delay(4000);
server.begin();
Serial.println(“server.begin Complete”);

I have also noticed that the LED on the board “100M” is just about emitting (not very bright at all as the other LED’s). But this could maybe just be as a faulty LED?

I was so exited in getting started with Arduino and spend about $100 on the board and modules that I want to play with and now I am not able to do this simple task.

:slightly_frowning_face:

I have also read that if you use a SD card that I need to set pin 4 to low or remove the card. I have no SD card in the arduino and i have also tried to set it to low. There is nothing connected to the pin headers. I though that maybe the usb power is not sufficient and added a 12V DC power to the power connector without any success.

Please let me know if I am missing something stupid.

Thank you

vissie

With no changes to the code, the IP has changed to 0.45.45.45 ?

Nevermind. I found the solution. From the arduino website the latest version for the IDE that i got was 1.6.6. I found found version 1.7.7 which included the Ethernet2 library and it also now has the option for the Board "Leonardo Eth"

I have downloaded the latest IDE from http://www.arduino.org/blog/1-the-new-blog/new-arduino-ide-1-7-7

Seems there is massive confusion between arduino.org and arduino.cc ...