Leonardo giving me problems

I just purchased a Leonardo and I'm having issues with it on 7. I plug it in and for about ten seconds it recognizes the device as an Arduino Leonardo under "Other divices". Then it switches to an unknown device under usb controllers. I rush to check the hardware ids before it changes and get USB\VID_2341&PID_0036&REV_0001 USB\VID_2341&PID_0036 Under unknown device it has no information whatsoever.

When I try updating the drivers windows tells me it already has the best drivers for it. I've tried the 1.0 and 1.01 ide's drivers and none work. Could it be a bootloader issue? I also have a duemilanove that works fine.

Thanks in advance, Strix

Yeah, the Leonardo is a fussy one. First thing I can suggest is to try another USB port. Not all USB ports are made equal when it concerns Windows.

Second is to find a USB hub to test for stability. I noticed that with my Leonardo, it would hang during the sketch upload. When I switched to the USB hub, that eliminated that problem. Also, make sure you have all your Windows 7 updates.

Lastly, try eried's modified IDE. It is pretty slick with the driver installation. http://arduino.cc/forum/index.php/topic,118440.0.html

Thanks, I'll try the modified IDE. As for USB ports, I tried all of them on two laptops and a desktop all with all x64 win 7 updates. I'll try a hub if the IDE doesn't work but I won't get to check it until Tuesday so if anyone else has troubleshooting suggestions please feel free to post.