macOS Big Sur, Arduino Nano Every, Arduino Mega: Only When Arduino Nano Every is Connected, No "Relevant" Port is Found

Hi all,

I have a peculiar issue and would appreciate any input.

Devices

  • MacBook Pro 15inch Retina, macOS Big Sur

  • Arduino Nano Every (genuine)

  • Arduino Mega (genuine)

Issue

When I connect the Mega to either of my USB ports, I see the appropriate port. However, when I disconnect Mega and Connect Nano Every, no port shows up.

What should I do?

Make sure the USB cable is completely plugged into both the Arduino board and the PC.

You may have a damaged/defective or charge-only USB cable. Try a different cable.

Either of the above can result in the power connections being made (and thus LED lights on the board), but no data connections (and thus no port for the board).

Thank you for your input. I tried both of those (2 different cables, 2 different Nano Everys) but the issue persisted.

Is there a particular cable brand you'd recommend? What else could be going wrong?

I haven't done a lot of cable shopping because I've ended up with a huge accumulation of them over the years, including some of those pesky charge-only cables.

Generally, if you can use the cable for data on another device then it should be fine for use with an Arduino board. There might be some rare cases in which a cable is damaged in a manner that causes it to still get electrical connections on one device but not on another, but that would be a very rare occurrence.

Got it. I'm going to test another cable. I looked online to see if Nano Every comes with any "special" getting-started instructions, but could not find anything.

Beyond cable issues, where else do you suspect the issue might be coming from?

Unfortunately, I don't have an idea about that. I don't have a lot of experience with macOS.

With Windows, it would be drivers, with Linux udev rules. But my understanding is that no special configuration is required for macOS:
https://www.arduino.cc/en/Guide/NANOEvery#installing-drivers-for-the-arduino-nano-every

OSX No driver installation is necessary on OSX.

Have you installed the Arduino megaAVR Boards platform?

The Arduino IDE comes with support for the Mega pre-installed, but for the Nano Every you need to install the boards platform via the IDE's Boards Manager.

Even before installing the MegaAVR board support in the Boards Manager you should be seeing both the Mega and Nano Every if the cables are correct. No drivers need to be installed.

I'm on Catalina (not running Big Sur) and see the following with a Mega, Nano Every, and a Leonardo attached:


Admittedly they do (all) use different USB interface parts but they are functionally identical so if one of these is recognized they all will be (this doesn't apply to clones that use FTDI chips).

I just booted into Big Sur and I get the same results. All boards do show up. I even tried it connected through a Thunderbolt-3 hub instead of directly to the USB ports on my iMac.

Beautiful, thank you!

Apparently it doesn't need to...

I see them appear under System Preferences → Network, but that doesn't matter here. That's if you want to connect using a modem, and even then you don't need it. (Use the "screen" application from the command line.) You should see the devices in /dev if you view from the command line.

tom@tom11 ~ % ls -l /dev/cu.usb*
crw-rw-rw- 1 root wheel 19, 5 May 26 13:35 /dev/cu.usbmodem141101
crw-rw-rw- 1 root wheel 19, 9 May 26 13:35 /dev/cu.usbmodem141201
crw-rw-rw- 1 root wheel 19, 7 May 26 13:35 /dev/cu.usbmodem141401
crw-rw-rw- 1 root wheel 19, 11 May 26 13:35 /dev/cu.usbmodem904NTABBN0482
tom@tom11 ~ %

But if you are seeing the Nano Every there, maybe there is something wrong with you Arduino IDE installation.

The issue was with the cable...
4 cables didn't work. Last one did.

1 Like

What unfortunate luck!