MacOS Catalina :: Arduino IDE crashes when Serial Monitor opened

[MacOS Catalina (10.15.3), MacBook Pro 2014, Arduino Mega 2560]

As per the title. I've tried Arduino IDE 1.8.12, 1.8.11, and today's nightly build, but they all have the same behaviour. When I attempt to open the Serial Monitor, the IDE crashes, every time. (I can see the monitor window appear very briefly on-screen just before SIGABRT, and everything disappears.)

I am relatively new to Arduinos and the Arduino IDE. Since I installed a couple weeks ago, I've had numerous IDE (1.8.12) crashes whilst editing my programs. In an attempt to mitigate these crashes, I installed Arduino IDE (1.8.12) in my MacOS Mojave VM (running under Parallels) and the IDE there is stable. However, I am unable to get the VM to see the Arduino's USB port and thus need to compile/upload my programs on my Catalina host; an awkward work-around.

I've also installed and tried using a Xcode template that builds/upload for the Arduino. Whilst the template works fine, I'm not receiving any data in the 'screen' session it opens when I run my project, so I've reverted back to the Arduino IDE for now.

For my current project, I need to use the Serial Monitor, and later will need the Plotter. The IDE crash is now a big issue for me as I'm not able to use either my VM guest nor my host, to test my project.

Any tips are welcome.

(Crash log attached.)

Arduino_1.8.12_CrashLog.txt (145 KB)

It sounds like this bug:

Try the test build you can download from the link here:

Thanks Pert, however it didn't work. Same problem.

After reading your comment and the GitHub thread, I noticed that Arduino IDE flashed the Serial Monitor in the bottom right corner of my second monitor (whilst the IDE was opened and displaying on the built-in monitor).

I have a retina built-in screen and am using the full 2880x1800 resolution while my second monitor displays only 1920x1200. My screens are aligned one above the other not side-by-side.

Should I be reporting this here or at GitHub?
Are there build instructions for MacOS?

(Crash Log Attached)

Arduino_PR-9814-BUILD-924-macosx_CrashLog.txt (118 KB)

I have the same problem. The ide opens fine and can be run on any screen as a single window, but if I try to open the serial monitor while the IDE is not on the primary MacBook screen, the Arduino IDE crashes.

I am using version 1.8.12

The workaround is to use Arduino IDE 1.8.10. You can download it here:

I had the same problem w/ my MacPro (10.15.4) - in effect the same crash in the Java 2D thread - The solution that I found is to unplugged the second monitor.
That fixed it for me at least its the short term so that I can continue working.

I had this problem this morning. I have a Mac Mini running Catalina with two monitors. Arduino IDE 1.8.12 crashed when I opened the serial monitor, just like the original poster. My first solution was to install 1.8.10, and that worked - I could open the monitor, but I noticed it opened on the other screen from the IDE.

So my fix is to run the 1.8.10 IDE and open the serial monitor. Then move the monitor window to the same screen as the IDE. Then quit 1.8.10. When I then ran 1.8.12, the serial monitor would open up.

So then I tried a few experiments. While running 1.18.12 I moved the monitor window to my second screen. Arduino crashed, but it would start OK again (because the config file hadn't been changed to show the new window positions). Next I moved the main IDE window to the second screen. Again Arduino crashed.

It looks like the new IDE doesn't like any of its windows to be on the second screen