Mega 1280 won't program... sometimes

So. I have issues. Mega issues. And so does my Arduino.

So i am programming away making cool hacks and stuff, when all of a sudden BAM! the Arduino stops letting me program it.

It builds fine, but when it goes to upload, the Rx light flashes 3 times and the Tx light does nothing. then i get the old faithful of errors:

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Troubleshooting led me to unplug everything from it, use a fresh computer with a fresh version of the arduino IDE, and nothing worked.

I left it for a day in frustration, and then it worked! then i left it another day, and i have the same issue again.

Before it stopped working i was playing around with the Servodecode library. (http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1228137503)

AND i was printing serial over a 115200 baud rate for the first time.

i am bummed and would hate to have to get another one.

My Stats: Hardware: Arduino Mega 1280 Arduino IDE: v22 Computer: Dell Mini 1012 Netbook Windows 7 Ultimate

False alarm guys, i just smoked the micro. apparently it protests to 12V logic.

i would still like to know the answer, but i won't be able to test any solutions till i switch out the 1280 chip.