Mega 2560 Wifi R3 - not detected by serial, drivers not found by Windows

So I've got an Elegoo version of the Arduino Mega2560 with the Wifi chip ESP8266 onboard.

I have thoroughly read through what little documentation I've been able to find - none of which came from the manufacturer. The best resource that I've found so far, came from here: Arduino MEGA 2560 With WiFi Built-in - ESP8266 : 10 Steps - Instructables

So I set the DIP switches, downloaded the FTDI drivers, installed the drivers, restarted computer. No money. The Arduino/serial port is not detected by the device manager. Mind you, no other Arduino boards that I have, are experiencing connectivity issues.

I tried manually searching for the drivers. I found what I believe are the drivers - however, they still fail to install. (I attempt this by right-clicking on the unrecognized "Other Device" in my Device Manager)

I'm not exactly an electronics whiz, so anything that should be intuitive understanding, is completely lost on me. I'd just like to know what anyone else using this board had to do to get it to work. Maybe even confirm for me exactly what the drivers are named.

I believe that they are "ftdiport.inf" and "ftdibus.inf". Again, pointing to these files manually gives no love...

Is it not under Ports or is it not under Universal Serial Bus controllers? I went through the exercise of updating the FTDI drivers this afternoon. See 2.0 select port - #2 by sterretje.

I could not find an Elegoo Mega 2560 with WiFi on the web so I can't verify if it uses a FTDI TTL-to-USB or something else. Please make sure that it uses the FTDI chip. The TTL-to-USB converter on the board that is in your link seems to be a CH340 in which case you can download the drivers from http://www.wch-ic.com/downloads/CH341SER_ZIP.html; next unzip and run the exe.

No, it doesn't pop up under Ports or Universal Serial Bus Controllers, while it is unreognized.

Additionally, attempting to install the CH340 drivers, yields the following message:

"Not found install application, please install by hand!" :laughing:

You can try installing the driver via Windows Device Manager instead. I'll provide instructions:

  1. Open the Windows Device Manager.
  2. Connect the CH340-based board to your computer with a USB cable.
  3. You should see a new device ("USB2.0-Serial") appear under the "Other devices" section of the device tree. Double click on it.
  4. Click the Update Driver... button.
  5. Click "Browse my computer for drivers".
  6. Click the Browse... button.
  7. Select the unzipped folder of the download from the WCH website.
  8. Click the OK button.
  9. Click the Next button.

The driver should now install successfully. After that, the CH340 -based board should appear in the "Ports (COM & LPT)" section of the Windows Device Manager device tree as "USB-SERIAL CH340 (COMn)" and the board should show up under the Arduino IDE's Tools > Port menu.

1 Like

Ok, I got this to work. It was definitely the CH340 drivers that I needed.

Thanks for your help!

You're welcome. I'm glad to hear it's working now!

So then the next question is... Is there a manual (for dummies, so to speak) for the ESP8266? Assuming that one has little to zero knowledge of how wifi works, and this would be the segue to said knowledge?

I think that most of the info that I'm seeing assumes more than a novice level of knowledge regarding how IoT, in general, works.

Sara & Ruiz Santos have a site, https://randomnerdtutorials.com with extensive range of tutorials covering a broad range of uses of ESP32 & ESP8266. A bit beyond my skills but I'm getting value all the same.
mick