Mega2560 + Mega2560 as ISP to burn bootloader

Hi,
I have to burn the bootloader on my Arduino Mega2560. I’m using another Mega2560 as ISP, on which I uploaded the sketch “ArduinoISP”. Then I made the following connections between the two boards’ pins:

Mega2560 with the sketch Mega2560 to be programmed
50 50
51 51
52 52
53 RESET
5V 5V
GND GND

and the RESET of the board with the sketch is connected to ground with a 100nF capacitor.
After that I selected “Arduino as ISP” and then “burn the bootloader”; TX and RX started to blink and after a couple of minutes the IDE of Arduino gave me the following error:

avrdude: verification error, first mismatch at byte 0x1e000 0xff != 0x0d avrdude: verification error; content mismatch

and the board to be programmed started to blink.

What am I doing wrong? I have not any external AVR-writer and the only boards I own are Arduino Mega2560 and Arduino Fio.

Thanks for any help :slight_smile:

I'm trying to do the same thing and have got the same problem. Are any of the lights on the arduino you are uploading to blinking during the upload?

Use Nick Gammon's bootloader sketch instead. http://www.gammon.com.au/forum/?id=11635

I tried Nick Gammon's bootloader. It shows no errors but it still doesn't work.

Time for a real tool then: Atmel AVR ISP MKii http://www.atmel.com/tools/avrispmkii.aspx Don't install Atmel Studio. Install the driver that's in the Arduino IDE folders; search for avrisp2.inf to find the folder on your computer.