MKR1010 is not charging the battery

I have connected both the USB and the 3.7V LIPO battery to my Arduino MKR WIFI 1010, but the CHRG light has not been turned on.
Since the JST port fixes the way of connection, I don't think I connect the battery in a wrong way round.
I have tried both LIPO battery with 1100mAh and 500mAh, but none of them works.
After I disconnect the battery with the USB connection, the CHRG light sometimes starts flashing at a very high frequency, but it turns off after I disconnect and reconnect the USB socket.
Does it mean that the battery is not charged at the moment and if there is any way to figure out what is the problem?

Hi, this sometimes depends on the sequence of connecting the battery. The board detects the first power source connected to it. Try pressing the reset button after you connect the USB and battery and see if the charging starts.

Im actually having this same issue, my MKR1010 WiFi isnt charging the battery either. I am using a 750mAh that I got from Amazon. Ive tried different points of connecting it, resets, nothing seems to turn the charger light on and the battery remains dead.

So I just happened to find another post that someone mentioned to check the + and - connections in the JST as a lot of them came backwards. Just FYI, they were right. I checked the board diagram and it confirmed that my connector had the leads reversed. After I reversed them in the JST its now working.

1 Like

Yep that fixed my issue as well! Checked the diagram and the leads are swapped, swapped the JST leads and bingo bango it worked.