MKRFOX 1200 messages not sent; status "OK"

Hi,

First post on the forum here - many thanks to the community who have already solved a lot of the issues I have had so far, but I can't find any info or previous posts similar to my current problem so I have to ask!

I have a MKRFOX 1200 set up to measure temperature from a thermistor and sending data hourly - the board goes into low power sleep mode between sending. All works well with data received at the SigFox portal as expected initially - however, after some time (usually around 10 hours, sometimes less) the messages stop being received at the portal. The program is waking correctly, doing the analog measurement, sending the message, and getting status 0 (OK) from the SigFox.endPacket(); instruction, indicating that sending was successful (?), but nothing appears in SigFox backend messages. A reset of the board will normally start messages coming through again, so I think the problem is at the MKRFOX side.

My question is has anyone experienced a similar issue, or may be able to suggest a possible cause? I initially had some trouble with using non-debug mode (solved via an old forum post) and occasionally get a status "62" when trying to send & receive data (with endPacket(true)), but at least in that case the failure is detectable and I can retry.

The current issue is difficult to recreate (sometimes can take over a day to show up) - I thought I had solved it modifying the Sigfox.end() instruction - there is a pinMode(poweron_pin, LOW); line there that I think should be digitalWrite(poweron_pin, LOW); ?? However, the original issue returned after a day and a half of transmissions. I am planning to leave the device running in a remote location so it would be good to have some reliability!

Any suggestions welcome - at the moment the board is powered with a regulated 5V through Vin, although I plan to use the battery terminals later. I was not using any serial output, but am using Serial1 for debugging now.

Thanks
DK

Not familiar with the MKR family. But I think that it will help others to help you if you post the code (between [code] and [/code] , the so called code tags)

Thanks sterretje - the problem has been solved (I think) by moving to a location with better coverage. As far as I can tell, the issue was caused by loss of signal.

A more general question if anyone would know - does a returned status of “0” imply sending was successful? And if not, is there any way to tell if the message has been sent successfully?

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.