MPU6050 - invalid readings of the z-axis

Hi,
I recently bought an arudion uno and few sensors for my project and I have problem with one of these: MPU6050.

I downloaded library for this sensor from http://www.i2cdevlib.com and uploaded sketch with demonstrates dmp usage.
Link to the sketch: https://github.com/jrowberg/i2cdevlib/blob/master/Arduino/MPU6050/Examples/MPU6050_DMP6/MPU6050_DMP6.ino

When I uncommented OUTPUT_READABLE_REALACCEL and tried to get acceleration without gravity I got strange values from z-axis. It's look like that after ~10s x and y axes show values around 0 (expected) but z-axis never zeroes. I checked code of this library and it seems that all 3 axes are caluclated the same way. I also tried different MPU6050 unit (from the same vendor) and it behaves the same. Any suggestion what can be wrong?

Earth gravity.

The accelerometer should have about 1g for the earth gravity.

I assume that functions used in this example removes component of the gravity form x, y and z axes (completly). In such case if sensor doesn't accelarate values should be similar to 0.

I've been having the same problem since I got the chip in February. I get a consistent reading of around +1700 at rest on the Z axis, which doesn't correspond to anything that I'm aware of (gravity would be ~8000 when using the 2G scale, correct?). I posed a question to Jeff Rowenberg on the only forum I could find that he participated in but didn't get a response.

Would love to figure this out. Too late for a refund if it's a chip error but I doubt it is.