My esp8266 talk to me very badly in "rll⸮r$⸮n ⸮lrl" way

Hello everyone,

I'm new here, and i'm discovering the wonderfull word of esp8266.

I'm using the board "UNO+WiFi R3 ATmega328P+ESP8266, 8Mb flash, USB-TTL CH340G, Micro-USB"

After several issues regarding the CH340 driver problem, find a micro-usb who allow datatransmission,

i tried to upload this sketch into my esp8266 using
the following DIP configuration 1,2,3,4 -> off and for 5,6,7,8 -> on
and for the board : "Generic ESP8266 module"

void setup() {
 Serial.begin(115200);
 Serial.println("");
 Serial.println(" Hello world !");
}

void loop() {
  // put your main code here, to run repeatedly:
}

i get this

Executable segment sizes:
ICACHE : 32768           - flash instruction cache 
IROM   : 236020          - code in flash         (default or ICACHE_FLASH_ATTR) 
IRAM   : 26729   / 32768 - code in IRAM          (IRAM_ATTR, ISRs...) 
DATA   : 1496  )         - initialized variables (global, static) in RAM/HEAP 
RODATA : 900   ) / 81920 - constants             (global, static) in RAM/HEAP 
BSS    : 25616 )         - zeroed variables      (global, static) in RAM/HEAP 
Sketch uses 265145 bytes (27%) of program storage space. Maximum is 958448 bytes.
Global variables use 28012 bytes (34%) of dynamic memory, leaving 53908 bytes for local variables. Maximum is 81920 bytes.
esptool.py v3.0
Serial port /dev/cu.usbserial-1420
Connecting....
Chip is ESP8266EX
Features: WiFi
Crystal is 26MHz
MAC: e8:db:84:e4:45:4b
Uploading stub...
Running stub...
Stub running...
Configuring flash size...
Auto-detected Flash size: 4MB
Flash params set to 0x0340
Compressed 269296 bytes to 197708...
Writing at 0x00000000... (7 %)
Writing at 0x00004000... (15 %)
Writing at 0x00008000... (23 %)
Writing at 0x0000c000... (30 %)
Writing at 0x00010000... (38 %)
Writing at 0x00014000... (46 %)
Writing at 0x00018000... (53 %)
Writing at 0x0001c000... (61 %)
Writing at 0x00020000... (69 %)
Writing at 0x00024000... (76 %)
Writing at 0x00028000... (84 %)
Writing at 0x0002c000... (92 %)
Writing at 0x00030000... (100 %)
Wrote 269296 bytes (197708 compressed) at 0x00000000 in 19.2 seconds (effective 112.2 kbit/s)...
Hash of data verified.

Leaving...
Hard resetting via RTS pin...

but when i open the serial monitor and after press the MCU reset

i get this

i don't understand why because i use the good baud rate to visualise the information?

when i try after to upload this sketch to visualize the serial monitor using this
DIP configuration 1,2,3,4 ,7 -> off and for 5,6,8 -> on

i get this

so in the end i get the right answer "Hello World" but i don't understand why first i had to change the DIP confguration to obtain that, and i don't understand also why i still have this weird string before my "Hello World"

If someone could help me it would be great :slight_smile:

thank you in advance

it is the boot log at different baud rate. ignore it

try to set the Serial monitor at 74880 bauds (and change the Serial.begin() to match this)

Hello thank you for your answers,

so when i tried at 74880 bauds
i get this

load 0x4010f000, len 3460, room 16 
tail 4
chksum 0xcc
load 0x3fff20b8, len 40, room 4 
tail 4
chksum 0xc9
csum 0xc9
v00041bf0
~ld

 Hello world !

i still don't understand why i have to change the dip configuration to visualise "Hello World" on the serial monitor?
i'm using the DIP configuration "CH340 connect to ESP8266 upload sketch" (1,2,3,4 OFF and 5,6,7,8 ON) and for visualise the serial monitor i have to switch the pin 7
"CH340 connect to esp8266" (1,2,3,4,7 OFF 5,6,8 ON)

the difference between this two configuration is blurred for me

thank you and have a nice day !

Seems the very bad talk is gone :wink:

I never used a UNO+WiFi, it always seemed to me like a weird contraption that should not exist... so not sure about the dip switches

switch 7 is connected to io 0 of the esp8266. the esp8266 bootloader reads io 0 and if it is LOW then the bootloader waits for upload. if it is HIGH then the bootloader starts the sketch