my uno R3 is not recognized

Hello everyone, here's my problem : i have bought an arduino r3 few months ago from an official seller, and it was working great on my computer, wich had windows 7 (i had some troubles at first with the drivers, but I installed them manually and it worked fine)

i had some hard drive problems lately, and had to reinstall a new windows, and since then, i can't make my arduino work (I have windows 7 ultimate, on 32 bits)

when i plug the arduino, it light up, but i have absolutly nothing on my computer, even on the device manager, i don't have any "unknow device"

thank you for your help ! (and excuse my english, i tried to write the best i can ^^")

Check the arduino in another computer (to check if there is something with the arduino first)

I already tried on a laptop (also with 7) and I didn't work either

I have a mega that has the same problem. My Mac can not find the Arduino, but it lights up. Also the bottom of my board seems to have some blue spots that seemed to leek from the top. I would love to find out if it can be fixed.

Some keywords you both need now: dfu mode and bootloader. If other PC also fails with the arduino it is probably the small serial uC or the big uC (bootloader), but it is hard to provide instructions to fix them easily, you need to find and learn to heal your arduinos :(