Nano 33 BLE Kernel Panic after every upload

Hi guys,

Looking for help to resolve issue with standard Nano board (not clone) Macbook connects and shows working port (cu.usbmodem411) sketches upload, window shows uploading status, gets to about 95% then crashes mac. Funny thing is that I think the sketch uploads completely and works, Blink sketch flashes onboard LED.. but crashes after every upload. Re-installing the IDE didn't make any difference. Would posting crash error help?

Thanks Matt

MacBook Late 2008 El Capitan 10.11.6 Arduino IDE 1.8.10

Moved your topic to it’s current location as it is more suitable.

Could you take a few moments to Learn How To Use The Forum.
Other general help and troubleshooting advice can be found here.
It will help you get the best out of the forum in the future.

Posting tips.

  • Always list the version of the IDE you are using and the board version if applicable.
  • How to insert an image into your post. ( Thanks Robin2 )
  • Add your sketch where applicable but please use CODE TAGS ( </> )
  • Add a SCHEMATIC were needed even if it is hand drawn
  • Add working links to any specific hardware as needed (NOT links to similar items)
  • Remember that the people trying to help cannot see your problem so give as much information as you can

Bob.

Ok, I have read the guides, trawled through this site and spent time looking online but can’t find an answer to my problem and hope someone could help. I’ve got a standard Nano 33 BLE that I wanted to use to learn BLE for a project. Header pins were soldered on and I installed the Arduino IDE (1.8.10)

There is no circuit, I’m connecting the board directly to a Macbook so I can check that everything works and I can upload sketches. I’ve tried different USB cables and have been using a WD drive cable that I know works as I have been using it for time machine backups. I’ve tried a clean install of the IDE, downgrading the board version and did a clean reinstall of El Capitan on my Macbook (nightmare) I’ve also repeated this setup on another mac (iMac 24") but the problem is exactly the same.

After the initial setup there were some Java error messages so I have updated Java. When I first started connecting the board the RGB led would flash colours but has since stopped.

The problem is that every time I upload a sketch the Macbook has a kernel panic and crashes, this also happens occasionally when connecting or disconnecting the board but not all the time. If I try to upload a sketch without a port selected it reports an error but does not crash.

Steps:

  • I’ll edit the Blink sketch and alter the blink delay so I can tell if the sketch actually uploads.
  • Select the board from the tools menu.
  • Double click the reset button on the board (Led pulses slowly)
  • Select the port (Either cu.usbmodem411 or cu.usbmodem611)
  • Click upload, window reports progress, normally up to about 94% then always crashes mac.

Hopefully, I’ll post some pics and a crash report and any help would be greatly appreciated.

(mod edit)

Kernel_MacBook.txt (8.33 KB)