Nano reset button?

Hi folks, I have an Arduino Nano look alike (describes itself as an Iduino) which has a button in the middle of the board. Is this supposed to be a reset button? Pressing it does not reset my board. I wold just like to confirm that this is really a reset button because I cannot find anything on this site that describes this button.

Thanks!

Yes, that is a reset button. See the schematic here:

What makes you think the reset is not working? It should restart the last uploaded sketch.

If it doesn’t restart the sketch try shorting the Reset pin (between +5V and Gnd) to Ground (Gnd) to perform the reset. If that also doesn’t work it sounds like you might have a broken trace in the reset circuit.

Hi John, Thanks for the reply and the pointer to the schematic.

The reason I think the reset button doesn't work is that with a blinking LED sketch running, there is no interruption (*) in the blink. Touching the reset pin to ground resets instantly.

(*) If I mash the button enough, it resets so I suppose the button is flaky or perhaps there is a cold solder joint between it and the circuit board.

Edit: I should really test all of the other inputs and outputs to make sure they work. Edit #2: I ran a digital output sketch and all pins worked (except, of course, A6 and A7.) I did not try inputs, presuming if outputs were good, inputs would as well. Analog inputs nearly as good. All worked except A7. Using a 10K pot for the AnalogInput example sketch, it read a solid zero through the entire sweep of the pot. Checking voltage it pulls the voltage to nearly zero as well, so it must have a short somewhere.