permission denied dev/usb7

Tried on several machines under different usernames. the error message permission denied dev/usb7 keeps coming up when we upload the program to the board.

The user logged into the Windows XP machine has admin access provided through a group "Tutors" to the machine. Not sure what these permissions are about??

We have tried different user settings but keep getting this same error message.

It works well on someones personal laptop though...

Has anyone faced this problem before??? HELP!!

Strange, I haven't seen any boards on dev/usb7 before - they're usually on com3 or something.. What board are you using? Did you select its com port from the Tools > Serial Port menu?

I’ve posted about this elsewhere, but I can tell you that yes, the correct port was selected, and we know it’s the correct port because Device Manager tells us which one is the USB<->Serial.

My mistake- it was always dev/com7, not usb 7. Here’s the error in full:

Error inside Serial.()

gnu.io.PortInUseException: Unknown Application

at gnu.io.CommPortIdentifier.open(CommPortIdentifier.java:354)

at processing.app.Serial.(Serial.java:127)

at processing.app.Serial.(Serial.java:72)

at processing.app.Uploader.uisp(Uploader.java:156)

at processing.app.Uploader.uploadUsingPreferences(Uploader.java:78)

at processing.app.Sketch.upload(Sketch.java:1693)

at processing.app.Sketch.exportApplet(Sketch.java:1755)

at processing.app.Editor$40.run(Editor.java:1892)

at java.awt.event.InvocationEvent.dispatch(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.run(Unknown Source)

Error: Permission denied
→ /dev/com7

I’ve tried exiting programs that might try and grab the same port, but I’ve had no luck so far. >:(

So far so good! ::)

I think I might have this licked- there were a couple of pieces of software running that were grabbing the port. The solution:

  • Disable on startup any program that might use the port.
  • Restart
  • Enjoy