Problem starting with Arduino Mini

Hi all. I'm having problems with my first Arduino Mini, perhaps someone will have some ideas.

Gianluca says the bootloader should be on it. After reset I observe no blinking on an external LED from pin 13. I have also tried to program it via the tx and rx of an arduino NG board minus the atmega chip, but I just get programmer not responding (tried flipping tx and rx, too).

What I've tried, in more detail... Circuit 1: http://www.flickr.com/photos/neillzero/290667170/

I power the mini via arduino NG's +5v and gnd headers. From pin 13 to ground I have an LED and 220 ohm resistor. If I instead connect the LED to pin 4 it lights, proving that the LED is in the right way and that +5v is indeed being provided to that pin.

The LED doesn't blink on pin 13. I would expect it to do so after 10 seconds, once the bootloader realises there's no program coming through and reverts to the previous program. Assuming the bootloader's there. Assuming the previous program is the test program.

Circuit 2:Powering from a 9v battery doesn't make any difference. (The only other difference here is I'm taking the +ve rail to the +9v pin on the mini) http://www.flickr.com/photos/neillzero/290676799/

In circuit 1 and 2 I reset by taking the reset pin low momentarily.

Circuit 3: Here's how I'd do a reset switch if I got the thing to run at all. http://www.flickr.com/photos/neillzero/290678937/

It's the same as circuit one but with a reset switch which takes the reset pin low (it is pulled high through the resistor in top left (which goes to +5v) when the switch is not pressed, making sure it is not accidentally reset.

I tried to program it via the tx and rx of an arduino NG board minus the atmega chip, but I just get programmer not responding (tried flipping tx and rx, too). For this, I followed the same instructions I wrote up on the Arduino Mini wiki page.

So i think there are 4 possibilities: 1. I have wired it up wrongly, or am not resetting correctly. 2. I have damaged the mini. (No, I haven't powered it backwards, or with more than 9v.) 3. the mini doesn't have the bootloader on it. 4. The bootloader is there, but there is another program loaded which does not blink pin 13. (but then I should be able to program it).

Thanks for any ideas. Once it's running, I'll continue the documentation with a "getting started" article on the same page.

Neill

If the bootloader's there, it should blink/flash pin 13 when you reset the board, regardless of which program is currently on the board.

Normally, you need to tie the reset pin high, and bring it low to reset it. If it's disconnected, the board can reset continuously. Did you have the same problems with the pull-up resistor and push-button connected to the reset pin?

Great photos, btw. They should be very helpful to other people working with the Arduino Mini.

Yeah I have the same behaviour with the later circuit which holds the reset pin high. I repeated all tests with that circuit, and saw no light whatsoever from the LED on 13.

Thanks for the clarification, I get it now - immediately after pressing reset, I should get a brief ( < 1sec) flash on pin 13. I see that on a normal NG, but not on my mini.

As far as you can see in those photos, I’m using the correct pins, right? If you okay the circuits then I can link to those as examples from the Arduino Mini page.

good photos: thanks. even short youtube video clips wouldn’t be going too far for documentation to help newbies avoid misinterpretation of the order and timing of reset and download, or expected blinks, etc.

Any other diagnostic tips welcome. Time to buy another mini?
Neill

Did you check everything with a multimeter? Also measuring the voltage on the reset pin when the reset button is pressed? I think you have the right pins. Does the LED on pin 13 light up at all? Your breadboard doesn't have breaks in its power and ground rails, does it?

Thanks David, I tested voltages with a multimeter just now. I had already tested continuity, and was previously using the LED to check various pin states. In all cases below I've also measured voltage on the mini's pins directly (and carefully) to remove the question of breadboard continuity (though I'm confident about that).

Reset: With the pushbutton circuit (#3), the reset pin sits at 4v, and goes to 0v when my reset is pressed. I guess I'm dropping 1v over that 10k pull-up resistor. (I've also repeated the experiments just by taking reset directly low then high connecting to ground or +5v with a jumper wire.)

Pin 13: stays 0v at all times.

Rx and Tx: are 0v at all times. (I'd read somewhere that I should consider tieing Rx to something, to avoid confusing the bootloader. I haven't done that yet.)

The only pins high on the mini are +9v, +5v (both at +5v) and reset (at +4v).

Unfortunately, I'm not anywhere near anyone who'd have another mini, or I'd just swap it into this ok-looking circuit.

neill

Here's an update. (Short story - the Arduino Mini I was using either was dead or had no bootloader.)

I replaced the Arduino Mini with another into exactly the same circuit, made no other changes, and everything's working fine. Looks like the old Mini was dead, or at least had no bootloader.

Here's the circuit I'm using:

With the new Mini, the LED on pin 13 blinks briefly (3 times in roughly 1 second) when the board is initially powered or thereafter reset. It also repeats this 3-blinks behaviour every 10 seconds. Guessing there had been no sketch loaded into this Mini (fresh from pcbeurope.net) so the bootloader is just waiting until the end of the receive-new-program window and starting over.

So, I went ahead and programmed it via an emptied Arduino NG, as I documented here: http://www.arduino.cc/playground/Learning/ArduinoMini

...and it's running fine! Thanks for the help.

I guess I'll have to look at trying to put a bootloader on the first Mini, to see if it responds. It saw a fair bit of static at the workshop, but certainly no reverse-wiring, or > +9v, etc.