Problem uploading to new board: Arduino Nano 33 BLE

Hi there,

I have just bought 2 new Arduino Nano 33 BLE boards without headers,

and I’m not able to get any program to upload with them.

Trying the example blink code…

If I select the board and port: Arduino Nano 33 BLE, I get an error message even on compiling the blink code as follows:

Arduino: 1.8.13 (Mac OS X), Board: “Arduino Nano 33 BLE”

/private/var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/AppTranslocation/3A0EE5AC-7F19-411B-8076-768B0F5BC9B1/d/Arduino.app/Contents/Java/arduino-builder -dump-prefs -logger=machine -hardware /private/var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/AppTranslocation/3A0EE5AC-7F19-411B-8076-768B0F5BC9B1/d/Arduino.app/Contents/Java/hardware -hardware /Users/jessicamardon/Library/Arduino15/packages -tools /private/var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/AppTranslocation/3A0EE5AC-7F19-411B-8076-768B0F5BC9B1/d/Arduino.app/Contents/Java/tools-builder -tools /private/var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/AppTranslocation/3A0EE5AC-7F19-411B-8076-768B0F5BC9B1/d/Arduino.app/Contents/Java/hardware/tools/avr -tools /Users/jessicamardon/Library/Arduino15/packages -built-in-libraries /private/var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/AppTranslocation/3A0EE5AC-7F19-411B-8076-768B0F5BC9B1/d/Arduino.app/Contents/Java/libraries -libraries /Users/jessicamardon/Documents/Arduino/libraries -fqbn=arduino:mbed:nano33ble -vid-pid=2341_805A -ide-version=10813 -build-path /var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/arduino_build_588325 -warnings=none -build-cache /var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/arduino_cache_917451 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/arm-none-eabi-gcc/7-2017q4 -prefs=runtime.tools.arm-none-eabi-gcc-7-2017q4.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/arm-none-eabi-gcc/7-2017q4 -prefs=runtime.tools.bossac.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/bossac/1.9.1-arduino2 -prefs=runtime.tools.bossac-1.9.1-arduino2.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/bossac/1.9.1-arduino2 -prefs=runtime.tools.openocd.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/openocd/0.10.0-arduino13 -prefs=runtime.tools.openocd-0.10.0-arduino13.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/openocd/0.10.0-arduino13 -prefs=runtime.tools.dfu-util.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/dfu-util/0.9.0-arduino2 -prefs=runtime.tools.dfu-util-0.9.0-arduino2.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/dfu-util/0.9.0-arduino2 -verbose /private/var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/AppTranslocation/3A0EE5AC-7F19-411B-8076-768B0F5BC9B1/d/Arduino.app/Contents/Java/examples/01.Basics/Blink/Blink.ino
/private/var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/AppTranslocation/3A0EE5AC-7F19-411B-8076-768B0F5BC9B1/d/Arduino.app/Contents/Java/arduino-builder -compile -logger=machine -hardware /private/var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/AppTranslocation/3A0EE5AC-7F19-411B-8076-768B0F5BC9B1/d/Arduino.app/Contents/Java/hardware -hardware /Users/jessicamardon/Library/Arduino15/packages -tools /private/var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/AppTranslocation/3A0EE5AC-7F19-411B-8076-768B0F5BC9B1/d/Arduino.app/Contents/Java/tools-builder -tools /private/var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/AppTranslocation/3A0EE5AC-7F19-411B-8076-768B0F5BC9B1/d/Arduino.app/Contents/Java/hardware/tools/avr -tools /Users/jessicamardon/Library/Arduino15/packages -built-in-libraries /private/var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/AppTranslocation/3A0EE5AC-7F19-411B-8076-768B0F5BC9B1/d/Arduino.app/Contents/Java/libraries -libraries /Users/jessicamardon/Documents/Arduino/libraries -fqbn=arduino:mbed:nano33ble -vid-pid=2341_805A -ide-version=10813 -build-path /var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/arduino_build_588325 -warnings=none -build-cache /var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/arduino_cache_917451 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/arm-none-eabi-gcc/7-2017q4 -prefs=runtime.tools.arm-none-eabi-gcc-7-2017q4.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/arm-none-eabi-gcc/7-2017q4 -prefs=runtime.tools.bossac.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/bossac/1.9.1-arduino2 -prefs=runtime.tools.bossac-1.9.1-arduino2.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/bossac/1.9.1-arduino2 -prefs=runtime.tools.openocd.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/openocd/0.10.0-arduino13 -prefs=runtime.tools.openocd-0.10.0-arduino13.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/openocd/0.10.0-arduino13 -prefs=runtime.tools.dfu-util.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/dfu-util/0.9.0-arduino2 -prefs=runtime.tools.dfu-util-0.9.0-arduino2.path=/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/dfu-util/0.9.0-arduino2 -verbose /private/var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/AppTranslocation/3A0EE5AC-7F19-411B-8076-768B0F5BC9B1/d/Arduino.app/Contents/Java/examples/01.Basics/Blink/Blink.ino
Using board ‘nano33ble’ from platform in folder: /Users/jessicamardon/Library/Arduino15/packages/arduino/hardware/mbed/1.3.0
Using core ‘arduino’ from platform in folder: /Users/jessicamardon/Library/Arduino15/packages/arduino/hardware/mbed/1.3.0
Detecting libraries used…
/Users/jessicamardon/Library/Arduino15/packages/arduino/tools/arm-none-eabi-gcc/7-2017q4/bin/arm-none-eabi-g++ -c -w -g -Os -nostdlib @/Users/jessicamardon/Library/Arduino15/packages/arduino/hardware/mbed/1.3.0/variants/ARDUINO_NANO33BLE/defines.txt @/Users/jessicamardon/Library/Arduino15/packages/arduino/hardware/mbed/1.3.0/variants/ARDUINO_NANO33BLE/cxxflags.txt -DARDUINO_ARCH_NRF52840 -mcpu=cortex-m4 -mfloat-abi=softfp -mfpu=fpv4-sp-d16 -w -x c++ -E -CC -DARDUINO=10813 -DARDUINO_ARDUINO_NANO33BLE -DARDUINO_ARCH_MBED -DARDUINO_LIBRARY_DISCOVERY_PHASE=0 -I/Users/jessicamardon/Library/Arduino15/packages/arduino/hardware/mbed/1.3.0/cores/arduino -I/Users/jessicamardon/Library/Arduino15/packages/arduino/hardware/mbed/1.3.0/variants/ARDUINO_NANO33BLE -I/Users/jessicamardon/Library/Arduino15/packages/arduino/hardware/mbed/1.3.0/cores/arduino/api/deprecated -iprefix/Users/jessicamardon/Library/Arduino15/packages/arduino/hardware/mbed/1.3.0/cores/arduino @/Users/jessicamardon/Library/Arduino15/packages/arduino/hardware/mbed/1.3.0/variants/ARDUINO_NANO33BLE/includes.txt /var/folders/8v/cjqpq0rj42794h9gd938gcc80000gn/T/arduino_build_588325/sketch/Blink.ino.cpp -o /dev/null -DARDUINO_LIB_DISCOVERY_PHASE
fork/exec /Users/jessicamardon/Library/Arduino15/packages/arduino/tools/arm-none-eabi-gcc/7-2017q4/bin/arm-none-eabi-g++: no such file or directory
Error compiling for board Arduino Nano 33 BLE.

If I select board: Arduino Nano and port: Arduino Nano 33 BLE I get an error on upload as follows;

Arduino: 1.8.13 (Mac OS X), Board: “Arduino Nano, ATmega328P” - see attached document for error transcript

I also tried the board Arduino Nano 33 IoT and no joy.

I am working on a Mac OS, Catalina v. 10.15.7. And Arduino v. 1.8.13
I have installed the Nano 33 BLE in boards manager (and didn’t receive a network preferences message box). I installed both the Ardiono SAMD Boards (32-bits ARM Cortex-M10+) and the Arduino nRF528x Boards (Mbed OS).
I have also installed the Arduino_LSM6DS3 and Arduino_LSM9DS1 libraries.
I have nothing else attached to the board except the USB.

I have tried both Nano boards and 2 different micro USB cables, and am still getting the same error messages. One micro USB cable is one I already had, the other was bought recently here… https://www.amazon.co.uk/gp/product/B0778FV6K4/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

Best
Jess

Arduino Nano error code.pdf (26.7 KB)

This error indicates something has gone wrong with the "Arduino mbed enabled boards" platform when it was installed via Boards Manager. The solution is to remove and then re-install the platforms.

Be aware this will remove any boards you have installed via Boards Manager. However, you can just reinstall them.

  • (In the Arduino IDE) File > Preferences
  • Click the link on the line following "More preferences can be edited directly in the file". This will open the Arduino15 (or similar name depending on OS) folder.
  • Delete the "packages" subfolder under the Arduino15 folder. Please be very careful when deleting things from your computer. When in doubt, back up!
  • (In the Arduino IDE) Tools > Board > Boards Manager
  • Wait for the downloads to finish.
  • Reinstall the "Arduino mbed enabled boards" platform and the platforms of any other boards you have.
  • Click "Close"

Be aware, also, that some people (like me) have reported problems with the 1.3 version of the mbed boards package. Using the 1.1.6 version may help.

Hey thanks, I'm afraid it's not going well :frowning:

I deleted the packages and reinstalled the mbed and bRF528z boards. (thanks for the suggestion, wwoofbum, I tried the 1.1.6 v of the mbed boards, but it didn't recognise the nano 33 without going to the 1.3 v).

But I'm still having problems..

One Nano board won't even upload the blink sketch - it tries to upload for an extended period, and eventually says 'no device found on cu.usbmodem14101. (and then crashes arduino).

The other one of the two Nano boards accepted the blink sketch. When if I tried the simple accelerometer example under the LSM9DS1 it worked once, but then the next time it got stuck on uploading and again returned 'no device found on cu.usbmodem14101

The IDE system has become unresponsive - it gets stuck on uploading, I click the serial monitor and it takes a minute to respond.

I tried an Uno board on the same port and that worked fine.

Best
Jess

Well, at least you got past the compilation error in your original post. It might not feel like it, but that is progress!

Try this:

  • Press and release the reset button on your board quickly twice. You should now see the LED on the board pulsing, which means the bootloader is running. The double press causes the bootloader to run indefinitely (until the board is reset, powered off, or an upload is done), which means you don't need to get the timing of the reset just right.
  • Select the port of your board from the Tools > Port menu. The port will be different when the bootloader is running so don't assume you already have the correct port selected.
  • Start an upload in the Arduino IDE.

Hi Pert, thanks for your help! took some perseverance, but I did eventually manage to get both boards going with the example sketches,

thanks
Jess

You're welcome. I'm glad to hear it's working now. Enjoy!
Per