Problem With Sending Data to Azure IoT Central

Hi everyone I'm new here,

just got my 1010 around a week and sent data to Arduino IoT cloud without any problem :D,

since I need more complicated dashboard component and function, I decided to send data to Azure IoT Central.

So first.

I found and followed this repository and this article step by step.

the problem is that I've read all the issue in the repository and tried so many times still can't send test data to Azure IoT Central.(also open a issue already.)

the message in my com port monitor is like :

16:48:04.885 -> Getting the time from time service: 
16:48:04.920 -> Current time: 29. August 2020 - Saturday 07:48:05
16:48:04.955 -> Getting IoT Hub host from Azure IoT DPS
16:48:15.020 -> Starting IoT Hub connection
16:48:25.205 -> ---> mqtt failed, rc=-2
16:48:37.233 -> ---> mqtt failed, rc=-2
16:48:49.262 -> ---> mqtt failed, rc=-2
16:49:01.284 -> ---> mqtt failed, rc=-2

Does anyone tried to sent data to Azure IoT Central before and got same issue or suggestion ?