Problème avec le nouveau YUN (V2.0)

Salut, on a acheté la nouvelle version du YUN (ABX00020). On aimerais installer nos package qu'on utilisait évidement sans problème avec l'ancienne version du YUN :
opkg update
opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-rt2x00-lib kmod-rt2x00-usb python-openssl ftplib

Tout semblerais s'installer, ormis la ftplib ... on a longtemps creusé mais rien ne marche jusqu'a présent, les messages reçu sont les suivants :

Package kmod-rt2800-lib (4.9.91+2017-11-01-5) installed in root is up to date.
Package kmod-rt2800-usb (4.9.91+2017-11-01-5) installed in root is up to date.
Package kmod-rt2x00-lib (4.9.91+2017-11-01-5) installed in root is up to date.
Package kmod-rt2x00-usb (4.9.91+2017-11-01-5) installed in root is up to date.
Package python-openssl (2.7.14-10) installed in root is up to date.
Unknown package 'ftplib'.
Collected errors:

  • opkg_install_cmd: Cannot install package ftplib.

Avez vous une idée pourquoi ftplib ne s'installe pas... on l'a installé a partir du root http et cela ne fonctionne pas plus. Les idées commences à manquer, et sans ce package on ne peut pas continuer nos développement. Merci.

Ceci peut peut-être t’aider…

Comme j'ai dit j'ai tenté de passer par le root http, et sa ne fonctionne pas plus :

root@Arduino:~# wget http://downloads.arduino.cc/openwrtyun/1/packages/ftplib_3.1-1-1_ar71xx.ipk
Downloading 'http://downloads.arduino.cc/openwrtyun/1/packages/ftplib_3.1-1-1_ar71xx.ipk'
Connecting to 158.69.81.61:80
Writing to 'ftplib_3.1-1-1_ar71xx.ipk'
Cannot open output file: File exists
root@Arduino:~# opkg install ftplib_3.1-1-1_ar71xx.ipk
Unknown package 'ftplib'.
Collected errors:

  • pkg_hash_fetch_best_installation_candidate: Packages for ftplib found, but incompatible with the architectures configured
  • opkg_install_cmd: Cannot install package ftplib.

Désolé, tu es sous Linux, je suis sous Windows, j’ai fait ce que je pouvais…

Je suis sur putty sur windows

Oups ! Mais je ne connais pas plus...

Bonjour

Unknown package 'ftplib'.
Collected errors:

  • pkg_hash_fetch_best_installation_candidate: Packages for ftplib found, but incompatible with the architectures configured
  • opkg_install_cmd: Cannot install package ftplib.

opkg ne trouve pas de librairie ftplib acceptable (compatible) dans le dépot ou la version préalablement téléchargée ne plait pas à opkg et openwrt)
Pourquoi ? Il ya peut être un fichier log quelque part sur la machine qui précise la raison du refus.
Je remarque que le fichier ftplib téléchargé finit par AR71xx, YUN2 a un processeur AR9331...important ou pas ?
(J'ai 0 Yun et 3 Raspberry Pi et ne suis guère familiarisé avec la version d'openwrt adaptée à Yun)

Yun n'a pas suscité d'enthousiasme parmi les utilisateurs de ce forum .
Question de prix et de timing (Raspberry Pi est passé par là auparavant !!)
Tu trouveras plus d'utilisateurs de Raspberry Pi sur ce forum que d'utilisateurs de Yun toutes versions confondues

Le message que tu as laissé sur le sous-forum anglophone dédia aux Yun devrait apporter une réponse si celui-ci ne peut le faire .