Problems in SIM detection


I am using SIM 900 module along with Arduino UNO. I am using AT commands for GSM communication(via softwareserial). And when I switch on the power along with the SIM inserted into GSM module, it starts detecting the SIM within 5-10 seconds, but the moment , the GSM goes into an area where there is no network, the GSM is not detecting the SIM card inserted into the module. After that the SIM is not detected even if the GSM module comes in the network range. The only way to make it functional is to restart the GSM module at the customer site by switching of and on the power supply. Please help me in this issue. Thanks in Advance.

You need to supply a lot more information to allow us to help you. Exactly what error messages are you getting?

I've not used the GSM module I think you're talking about, but I do know that on at least one GSM modem I've played with the CME error 013 'SIM Error' is pretty much the default error for a wide variety of issues.


I guess I have solved my problem. Actually you could understand the problem in a different way. Suppose you insert a SIM in card holder of SIM 900 module and plug-in the supply. After 10 seconds, it starts detecting the SIM. Now, keeping the power supply on, remove the SIM from module and reinsert it. Now it won't detect the SIM.

I have solved this issue by using AT+CFUN commands.

hi every one
My Objective:
i am trying to test my new GSM and GPRS modem that i brought from local electronics market. And i want check the functionality like sending and receiving SMS,CALLING,GPRS functionlity etc..

here i am going to specify 2 problems that i am facing....

for this i am trying to test this modem using AT commands...
these are the results that i am getting


+CFUN: 1


Call Ready

this error message i am getting when i am pressing "ctrl+z" to end the message.
And this Error : 302 is indicating that "Operation not allowed"
the simcard that i am using is postpaid ....

Another one is some times i also getting the following results..


+CFUN: 1


Call Ready


i found that when ever i powered on my Modem that voltage at the pins of the simcard reader is around 2.57V
and after some time it is becoming 0V then i am getting the



-> why the voltage becoming 0V after some time????
-> how to solve this problem???

which is indicating that sim card is not detected...

can any one who is reading this post help me out..

thanks in advacne

Hi there try to use this one
AT .........LF

test message. ......LF

Hello sankalp2891,

Can you share how did you solve the above problem using AT+CFUN command?

Can you share how did you solve the above problem using AT+CFUN command?

Hi Abhi,

Use command AT+CFUN=1,1 to restart the module & then wait for some seconds before executing further commands.

We have developed a customize board for GSM module using SIM800 IC. When the board was tested with the sim card of Reliance company then it was not detected but when I used the sim card of Idea company then it gets detected and all the AT commands runs using the module. Why only idea company SIM card gets detected and other Sim card are not? The error occured at AT+CREG? command which is AT command for network registration. For working idea sim it shows +creg:0,1 and for reliance it shows +creg:0,5.