Programing the Attiny84

Hello not sure if this is a programing problem or a hardware problem. I program the attiny85 in the past with no problem. But when now i go to program a attiny84 it seems like it works the Blink led sketch works the led blinks but if i disconnect the spi pins the D10 off of the reset pin on the attiny84 and D11, D12 and D13 the led stops working. i have it set to Pin 0 on the Attiny84 which is the second pin on there i follow this image correctly in wiring it up. i listed below and the Sketch of

/*
  Blink
  Turns on an LED on for one second, then off for one second, repeatedly.
 
  This example code is in the public domain.
 */
 
// Pin 13 has an LED connected on most Arduino boards.
// give it a name:
int led = 0;

// the setup routine runs once when you press reset:
void setup() {                
  // initialize the digital pin as an output.
  pinMode(led, OUTPUT);     
}

// the loop routine runs over and over again forever:
void loop() {
  digitalWrite(led, HIGH);   // turn the LED on (HIGH is the voltage level)
  delay(1000);               // wait for a second
  digitalWrite(led, LOW);    // turn the LED off by making the voltage LOW
  delay(1000);               // wait for a second
}

It seems to be working for the most part the led blinks and then i take off the pins just to add power and nothing happens can someone please help me out? Thank you.

Hello i also forgot i tried other pins and i get the same thing. i also tried another chip i have 2 and they come out the same.

Can someone please help me out Please?

Nevermind i figured it out it was the the arduino board programing the attiny chip i didn't set it as arduinp as isp. now it works.

Thank you for the follow-up.