Project 5 - can't add header pins?

Hi, As instructed I'm trying to add header pins to the female connectors on the servo motor. My problem is that they either won't stick to the servo connectors, or to the breadbord. If I put the short side of the pins in the servo, they are to short to stick properly. But if I turn them around so that the long pins are in the servo, the short pins won't connect properly to the breadboard.

Any thoughts? Have I been provided with the wrong type of header pins?

Hello there,

the pins you got were right, you just have to press the plastic piece down a bit. I had the same problem but now it is solved.

I hoped this helped

Well, that made things MUCH easier! Thanks!

xinatron: Hello there,

the pins you got were right, you just have to press the plastic piece down a bit. I had the same problem but now it is solved.

I hoped this helped

Could you please elaborate on 'press the plastic down a bit'?

Do you mean slide the black plastic piece down on the male pin so that longer part of the exposed pin becomes shorter?

Or compress the white casing on the female connector?

Thanks!

Edit: I think it's the first option, seems to have worked for me, thanks.

Push the black plastic to the center of the pins, or remove the plastic and inset the pins 1 by 1

I had this issue as well. I just attached male jumper pins to the white ends and their respective spots on the breadboard.

How did you manage to move the black plastic down the pins?

You have to push quite hard but it works. Do it against a table or something like that.