Raspberry pi pico does not show its port # in IDE

Hello,

I am trying to make a Raspberry Pi Pico work using Arduino IDE, the Pico populates under board, but does not show up under port, it always shows up as a storage disk instead each time when connected to a computer’s USB port. I also checked it in windows device manager, the Pico does not show up in the list of ports.

Is there any one who had similar issue or who knows the solution?

Thanks,
Gu

1 Like

I had this same issue this morning. I clicked “upload” anyway, hoping a more descriptive error would appear, and once it had failed the Pico appeared in the list of ports. Not a scientific solution but it seemed to kick the IDE into having another look.

3 Likes

I tried upload many times and no lucky.

@bigsheep's solution worked for me as well. I'm running the IDE on a Mac. Initially it can't see the port but if you select the board and upload then I suspect the IDE forces the Pico into bootloader mode. Apparently you only need to do this the first time you upload a sketch.

According to the guy who ported the Pico to Arduino, you can also get it into bootloader by holding down the BOOTSEL button while plugging in the USB, but this didn't work for me.

1 Like

I also tried holding down the BOOTSEL button while plugging in the USB, but this didn't work for me.

@bigsheep I just could not get the pico to appear as a com port in Windows 10. I was about to launch it into the trash when I stumbled across your suggestion. I tried it in desperation rather than hope. It worked perfectly. Thank you very much. I now have a new toy to play with.

@bigsheep thanks for the suggestion, very weird behavior but worked perfectly!

Did you find a solution? I'm having the same problem

OMG, thank you, I just wasted 2 hours. This worked in seconds!!!!! E.g., just writing. Note: plugging in my pico, Explore opens showing files, but I just don't see the port. clicking Upload from Arduino_Code anyway was the magic trick.

1 Like

Wow. this worked for me too haha