[RC3] Using Multiple Serial Monitors Simultaneously

Hi
I'm trying to get a few demonstrations of the IDE together, as I was planning on making a video about it for my YouTube channel. However, I'm having problems with the "Using Multiple Serial Monitors Simultaneously" example that Arduino provides on their documentation page.

I have tried this using two Arduino Uno's, as well as with a Uno and an Arduino 33 IoT board, and I get the same results. In all cases, I get the text from BOTH boards on each monitor!

In other words, Instead of getting "Hello World!" scrolling on one monitor and "Hello Mars!" on the other one I get both screens displaying "Hello World!" followed by "Hello Mars!".

I have also noticed that the Serial Monitor doesn't really seem to care what port is selected, if I connect either board independently to the computer it displays its results on the Serial Monitor, regardless of which port is selected. Which I'm sure is part of the problem.

I'm using Linux (Ubuntu 20.04) for this, later today I'll try it on a Mac and a Windows computer to see if I get the same results.

Has anyone else observed this?

As an update, I just repeated the experiment on another Linux computer and on a Windows 10 computer. In all cases I received the same results, the output from both Arduinos is displayed on each serial monitor, instead of independently as the Arduino tutorial illustrates.

It sounds like both monitors are connected to the same USB port. I typically run several instances of the ide each in a separate workspace on Linux. The first time I tried it I was surprised it worked flawlessly, that was several years ago and still does. Currently I have 5 Arduinos connected but only one IDE I am using to monitor the data. I simply select a different port, it resets the arduino and displays the hello message that tells me what program is present with ver, rev, etc. If I want a different one I close the monitor, select the appropriate board then pick a different port and get another message from a different Arduino.

Well physically they are, of course, connected to different USB ports. And I have now had the opportunity to try it on two more computers, an M1 Mac and an Intel i7 Mac - same results. So now that makes 5 computers and three operating systems doing the same thing.

Also, the Arduino example showed Windows and as I said in an earlier post, I have tried it using Windows 10.

Any chance that you (or anyone else) can try and see if you can successfully follow the instructions? I'd love to see if it's just something I'm doing wrong, or if it really is a bug.

Hi @DroneBotWorkshop. Thanks for giving the Arduino IDE 2.0.0 release candidate a try, and for your report!

This is a known regression which is tracked by the Arduino IDE developers here:

So the tutorial is not applicable to the recent versions of the Arduino IDE.

If you have a GitHub account, you can subscribe to that issue to get notifications of any new developments related to this subject.

1 Like