[RESULU] je n'arrive pas a faire fonctionner mon SIM800L EVB

bon voila c'est le troisieme module sim800L que j'achete et je n'arrive toujours pas a le faire fonctionner
je pense que c'est au moment de la connection mais je ne suis pas sur.
je suis debutant et j'essai d'avancer sur mon projet creer un telephone portable arduino mais il faut pouvoir envoyer des messages et telephonner.
je ne sais pas quoi dire de plus, demandez moi et je vous repondrais

merci d'avance

Bonjour alpha
Commence par poster le schéma du câblage et ton code.

le 5V de l'arduino au vcc du module pareil pour le gnd ;
tx -> rx
rx -> tx

et pas de code j'utilise directement les commandes at

Bonjour

je n'arrive toujours pas a le faire fonctionner
je pense que c'est au moment de la connection mais je ne suis pas sur.
.........
le 5V de l'arduino au vcc du module pareil pour le gnd ;

Peu de chance que ça fonctionne, ces modules s'alimentent bien sous 5V mais ils ont besoin d'un courant beaucoup plus élevé que celui pouvant sortir d'une carte Arduino.

Prévoir une alimentation 5V 2A pour pouvoir 'accrocher' le réseau téléphonique

En utilisant la Loupe en haut à droite sur le site il sera possible d etrrouvers des échanges précédents sur ce forum à propos des SIM800L EVB

j'ai aussi fait le test avec une alim 2.5A et ça n'a pas non plus marché

Dans ce cas il faut donner içi les réponses du module aux diverses commandes AT utilisées....
Il faut assi décrire en détail le comportement des leds du module.

+Un tutoriel a-t-il été suivi ? lequel ?

AT -> OK

ATI -> SIM800 R14.18
OK

AT+CREG -> ERROR

AT+CPIN ? -> +CPIN: READY
OK

AT+CSQ -> +CSQ: 0,0
OK

AT+COPS ? -> OK
RDY
+CFUN: 1

les tutoriels:

https://letmeknow.fr/shop/fr/blog/94-tuto-module-gsm-sim800l-prise-en-main

https://letmeknow.fr/shop/fr/blog/95-tuto-module-gsm-sim800l---envoyer-un-sms

l'antenne est-elle correctement reliée au module ? (le petit connecteur coaxial est TRES fragile, idem pour le câble qui aux deux extrémités ne supporte pas les fortes torsions)

oui, avec une antaine de bonne qualitée (je crois)

la 2G est-elle toujours présente dans votre secteur ?

les modules fonctionnent en 2G???

en fait GPRS (2,5G ou 2G+)

oui j'ai bien une antenne 2G pres de chez moi

mais ca ne marche pas

quel est le probleme
vous pouvez m'aider??

Bonjour

Prodéder par étapes :

  1. Liaison série ?
    tester d'abord AT voire ATI pour vérifier la liaison série avec le module (RX et Tx, débit en bauds...)

  2. Réception radio ?
    tester AT+COPS=? (avec le signe égal et le point d'interrogation)
    Même sans carte SIM insérée cette commande permet de tester le fonctionnement de la réception radio , antenne comprise. Elle doit ,après quelques secondes, lister les opérateurs disponibles dans le secteur
    Dans les mêmes conditions AT+CSQ donne le niveau du signal radio reçu et la qualité de celui-çi (RSSI et BER)
    Une réponse voisine de +CSQ:26,0 indique un bon niveau et une bonne qualité

  3. Emission radio et Enregistrement sur un réseau ?
    Ensuite viennent des commandes avec une carte SIM et une bonne alimentation (5V 2A mini) pour tester l'enregistrement sur un réseau** AT+CREG** et AT+COPS? Ces commandes activent l'émission radio et vérifient la possibilité de la carte SIM à s'enregistrer sur un réseau

ca a fonctionné du premier coup, j'ai mis un condensateur de 2200 uf alim en 2A et ca a marcher Merci!!!!

Bonsoir

oui , l'ajout d'un tel condensateur est souvent décisif pour 'accrocher' le réseau !!

peux tu éditer le tire du message initial pour ajouter [RESOLU] en début de ligne ?

C'est bon