Seeed studio TFT touch shield, what gives?

Still quite new to this, but I have had some success playing around with the arduino. I have a couple of UNO's, an R3 and an R2, as well as a MEGA R3.

I walked into radio shack today and saw all kinds of new shields on the rack, as an impulse i bought a few of the cooler ones ( overpaid, i know :P ).

One of them being the seeed studio TFT touch shield.

First sketch I tried loading was for the touch screen, right away i got an error message from the IDE ( 1.0 ) about non ASCII characters. So I went into the folder and replaced all the "-"s in the folder name with "_"s. This seemed quite strange to me, so my first question i guess is why would they name the files one is required to download such that arduino wont recognise them? is this a 1.0 issue? I loaded the code to a UNO R2 board

Then I wanted to try the TFT examples, had to do the same re-naming, also had to load the So, now the code compiles and loads just fine, but nothing happens. If I open up serial monitor, I see the following; Paint

unknown driver chip 202 Then Nothing happens on TFT Now I have gone to the wiki page and tried to download the libraries that are labled for the 1.0 IDE, but they come up as corrupt. I am assuming that this TFT uses a driver chip that is not in the library that I have, but this just seems wierd to me, why sell a product at a national retail store and not provide the required library support for it. Am I missing something here? Has anyone else gotten this shield to work with the UNO?

I know this doesn't help too much, but I am new at this as well.

I bought this as well a couple weeks ago, it pretty much worked with all the examples for me. On the wiki at seeedstudio, there is a reference to a changed chip, and the demo code THERE has a statement that doesnt work. It's basically a "if it's using this chip, do this else do that" The statement that checks for the new chip doesnt work at all, I removed all of it, basically leaving the contents of the "else" clause and that worked.

I did NOT have to do that with the included library examples however.

I wasn't able to get it to work on my MEGA, but I think my mega may be having issues as it isn't working with a couple other things.

The text output is sure primitive with it it seems, at least if you simply want to print down the screen.

I have the same screen and it works on my uno and mega what you need to do is download the library: by clicking on:TFT & TouchScreen Libraries for Arduino 1.0 then use the examples that come with the zip not the one on the wiki.

If you need a simple GUI library for the v1 SeeedStudio 2.8" TFT Touch Screen check out this lib I just put up:

also you can see a little video of it at:

I've used several 3.2" GLCD displays from SainSmart that are identical to the Itead 3.2" 320 X 240 65K color, touch and Sd card displays... As much as I hate to give them money. I also use the UTFT LIB from Henning Karlsen and I will be implementing 2 Mega's both with the 3.2 320 X 240 display, Barometer, hygrometer and thermometer. I will have a 3208 display connected by some inexpensive Bluetooth radios ($5.99 W the At command set). This "Thing" will also have a radio (FM Stereo) and do basic X 10 control control... All for phase one. My point is... (finally) that the display's are available form Amazon local (almost).I ordered 2 for $38 - 39. They'll be here on Monday (2 day Prime shipping) and the warranty is "No Question" and Very Local... (Nevada or 1/2 day shipping time extra). I had a bad one and withing 2 minutes of reporting a failure to Amazon they had issued an RMA I then printed the RMA and have it boxed for return. Reasonably Nice compared to Ebay. Amazon Prime is Well Worth paying for.


IMPORTANT! The library files from the seeedstudio site are .tar files that contain a .tar file.

Windows downloads them as .zip which is why you get the corrupt archive messages. If you rename the .zip file to .tar and extract, you will get a file without an extension. Just add .tar to the end of the extracted file. Extract the contents of the second .tar file and you will have the libraries.

I picked one of these up today, I never did get the old 1.0 ones to work and I've tried every library out there for tft. The 2.0 ones worked perfectly right out of the box. The zip opened fine for me, if it was tar I didn't notice and I didn't receive any errors. The folder itself, after I put them in the libraries folder, I did get the characters error message so I just took the "-master" off the end of each folder name and I did not get the errors. Ran a few of the demos (circles, draw) and it came right up.

I picked a few of these up today on clearance at 11$ each at radioshack.

Few things to get it to work. - seeedstudio github files needed - Needed the adafruit touch screen library - point should be changed to TSpoint - If using an arduino, change the pin assignments, If using a mega it will be different(refer to schematic at seeedstudio wiki) - YP A2 - XM A1 - YM A0 - XP A3

After these changed it works perfectly

Thanks keebie81. Your suggestions worked for me.

Changed line 33 to say #define MEGA in tft.h changed sketch to match above; still only a white screen; anything else might make this work?