Sensor jsn-sr04t

Tengo este sensor para medir el agua del tanque de agua, ultimamente me esta empezando a alterar los valores cuando el tanque baja mas de 30cm de agua empieza a alterarse. Puede ser un problema de.corriente? Ruido? Consume mas corriente cuando mide.mas de lejos? Este lo alimento con la salida 5v de arduino uno.

Ayudaría que pongas un enlace del sensor.

Ahora veo que es un sensor ultrasonico. Haberlo dicho!!!

EDITADO: sensor jsn-sr04t

ultimamente me esta empezando a alterar los valores cuando el tanque baja mas de 30cm de agua empieza a alterarse.

Quieres decir que cuando tu tanque tiene 30cm de agua y mide cuanto? porque supongo que el sensor lo tienes en la parte superior a qué altura?

Especificaciones técnicas

  • Modelo: JSN-SR04(FZ1655)
  • Voltaje de Operación: 5V DC
  • Corriente de trabajo: 30mA
  • Rango de detección: 25cm-450cm
  • Precisión: puede variar entre los 3mm o 0.3cm
  • Frecuencia de emisión acústica: 40KHz
  • Duración mínima del pulso de disparo (nivel TTL): 10 μS.
  • Tiempo mínimo de espera entre una medida y el inicio de otra 20 mS.
  • Ángulo de detección: menor a 50º
  • A prueba de agua (parte delantera)
  • Diámetro: 22mm
  • Longitud: 17mm
  • Temperatura de trabajo: -10ºC hasta 70ºC

Leo de 25cms en adelante, no será que lo tienes mal montado? Esperaré tus respuestas.

Si eso lo se, lo tengo puesta en la parte superior del tanque, el tanque lleno tiwne 92cm cuando esta lleno se mantiene perfecto cuando baja el agua y pasa los 70 empieza a volverse loco..

Loco como? puedes poner una captura?
Sacaste el sensor y lo hiciste que mida contra una pared las mismas distancias. de la distancia minima a los 92cmts?

Por cierto, dejé pasar algo que ahora te responderé.
El procedimiento de lectura de un sensor ultrasónico es siempre el mismo, se manda un ECO que es el mismo, y se espera su recepción. Eso no cambia si esta mas o menos cerca del obstáculo. Por lo tanto, no puede consumir ni mas ni menos a mas o menos distancia.

Loco seria que me tira cualquier valor hace saltoa de 30 a 60 es un ejemplo capaz esta en 31cm y de golpe salta a 50 y de nuevo baja y asi...

Tanque de agua... que raro. He visto ese comportamiento en tanques de productos químicos donde se producen burbujas de gases.

Te recomiendo que hagas la prueba del sensor en condiciones controladas, como dije, contra la pared y lo llevas de 25cmts y aumentas hasta su zona de error.

Si se vuelve a producir, tiendo a creer que tiene alguna falla, pero no puedo afirmarlo.

Dale lo voy a probar fuera del tanque, te aclaro que lo alimento de la salida de arduino uno y aparte de ese sensor alimento tambien un sensor de temperatura y humedad.

Si pero esos consumos no son disparatados.

Revisa la tensión del arduino mientras hagas las pruebas, tomas todas las precauciones.

Revise todo saque el sensor y contra la pared funcionaba perfecto lo volvi a meter en la tapa del tanque y volvio a funcionar todo perfecto, sera que se pudo haber movido de la tapa y quedo medio torcido otra no se me ocurre. Pero ahora anda bien...

Vaya rareza.. pero un antecedente para tener en cuenta.