"Serial Port not found" and "Error while opening Serial Port

Ok so I was doing a project with arduino and processing, and I ran into the problem where both of my arduino(the mega 2560, and the uno) can't be programmed. Originally I was using a raspberry pi to program them, but when i kept getting the errors, I tried to program them with my windows 10 laptop. I got a fresh usb cable, I tried using a blank code:

void setup() {
}

void loop() {
}

I also tried the blinky example:

/*
  Blink
  Turns on an LED on for one second, then off for one second, repeatedly.

  Most Arduinos have an on-board LED you can control. On the Uno and
  Leonardo, it is attached to digital pin 13. If you're unsure what
  pin the on-board LED is connected to on your Arduino model, check
  the documentation at http://arduino.cc

  This example code is in the public domain.

  modified 8 May 2014
  by Scott Fitzgerald
 */


// the setup function runs once when you press reset or power the board
void setup() {
  // initialize digital pin 13 as an output.
  pinMode(13, OUTPUT);
}

// the loop function runs over and over again forever
void loop() {
  digitalWrite(13, HIGH);   // turn the LED on (HIGH is the voltage level)
  delay(1000);              // wait for a second
  digitalWrite(13, LOW);    // turn the LED off by making the voltage LOW
  delay(1000);              // wait for a second
}

Error on raspberry pi says "Serial port '/dev/ttyACM0' not found." On the laptop, it says it uploaded, but the arduino doesn't do anything. Any help will be greatly appreciated! thanks

SteamTooth72: On the laptop, it says it uploaded, but the arduino doesn't do anything.

Was that with the Blink example or with the empty sketch?

That was with the blink code, I am so confused by it.

OK so for anybody reading this later, I left it alone for 3 days and it works now.