Serial port not found

When connecting Arduino Mega 2560 (along with another mega/uno) via usb cable it does not show as an option. I'm running the latest Mac OS Mojave Beta and Latest Arduino (even tried the Beta). I've attempted removing and reinstalling Arduino multiple times, removing and reinstalling the drivers, restarting my system, as well as trying multiple cables, ports, computers (2 Macs and a windows experiencing same issue with different Arduino units). I have also noticed that it appears that none of the units appear in any of the computers system information > usb pane or show as being connected to the windows. Any Suggestions?


I have am using a clone Sunfounder, but the issue started for all at once and the other 3 are brand new.

Does anyone have any suggestions?


I have a genuine Arduino Uno and a known working cable(tried 3, 2 old and a new) and even the Arduino Uno does not identify.



If tried multiple ports, usb drives, phones and mice show and work fine. I've also tried windows 10 and a Mac running Mac OS High Sierra. Still nothing.


Is there anyway to download an older Arduino version? Before the other night they they worked find and I see no reason the new ones I had purchased would not be working.


I'm with you... New to Arduino, Painfully familiar with Mojave breakage.

w/r/t serial port not discovered

This could be a wild goose chase... but there was no USB driver in

Some forums claim this driver:
"Obtain the file CH34x_Install_V1.4.pkg"
will solve the problem.

I did that and now there is this:
but nothing in Systems/Library/Extensions

AND - no serial port is discovered by Arduino.

So it's still not working.
Maybe some progress.. but not there yet.