Servo not moving at all

We started working with the Arduino Engineering kit, and started working on the Drawing robot and everything seemed to go well.
But after a few days, when we continued to work on it, the servo motor did not start to move. We tried different versions of the MKRMotorCarrier library and we uploaded the firmware from the Flasher (we tried with both the 0.6 and 0.11 versions) example. The DC motors work as intended.
The MKR1000 microcontroller included in the kit stopped working(the laptop didn't recognize the port, the controller overheated, we couldn't upload a code onto it) , and we bought another MKR 1000 microcontroller, but the issue has not been resolved. We used the 4 pins for servo motors and we changed the code for the appropriate pin, but the servo never continued to work. We tried the servo with a different microcontroller and it works as intended. We also tried connecting a different servo motor to the carrier and it did not work. We also had issues with the battery charger, as only one LED light was flashing green when connected, but since then we got another charger and another battery, so the issue is not the power supply.
When we try the test code in Chapter 3.3 the serial monitor shows us that the servo moves, but when in reality it does not. We will provide you with a link to the video showing this.
This is the link to the video: VID_20201217_225123.mp4 - Google Drive