Sim800l sim simyo

Hola buenas, estoy en madrid y estoy intentando acceder a internet con una sim de simyo probando con el apn de simyo y orange:
https://wiki.bandaancha.st/APN_de_las_operadoras_para_configurar_el_módem_de_Internet_móvil_3G/4G_LTE

Yo detecto con el comando AT+COPS=?, qué comando debería usar? Tengo cobertura de simyo cómo tal?

Captura de pantalla 2021-05-31 a las 18.34.52

Hola
El comando "AT+COPS?" (sin = ) te debe devolver la operadora conectada (Simyo en tu caso)
Prueba "AT+CSQ" para ver el nivel de cobertura.
Por cierto, ¿el pin de la sim está desactivado?

Saludos

Gracias por contestar tan pronto. AT+COPS? me devuelve 0, no conectado. A T+CSQ me devuelve 0,0.
El caso es que aún no he conseguido ni hacer una primera conexión. En ocasiones consigo configurar la APN, usuario y contraseña. Pero en el momento de usar AT+SAPBR=1,1 para conectarme al servicio me da error. También he probado con AT+SAPBR=3,1,APN,gprs-service.com pero creo que se debe usar la de orange aunque tenga simyo.

Antes que nada, quita el pin de la sim con cualquier móvil. Y olvídate de APNs.
Reinicia el sim y prueba primero ATZ y después el COPS? y el CSQ. Solo eso.
Si sigues con problemas y la sim te funciona con el móvil, casi te aseguro que el sim800 esta defectuoso
Saludos

Hola de nuevo, el comando cops? y el csq me siguen devolviendo lo mismo. También he probado a ejecutarlos después de un atz. Lo que he hecho es deshabilitar la petición de la sim y seleccionar desde el móvil que se conecte a redes 2G, y eso lo hace como tal, desde el móvil accede a los servicios gprs.
Lo que debería hacer ahora es conectarme desde el sim800l pero la verdad que no lo consigo, ciertos comandos me da ok y otros no. He probado tanto AT+SAPBR=1,1 como AT+CIICR para comenzar con los servicios gprs. De hecho me he fijado que con AT+CSTT puedes configurar apn, usuario y contraseña y si la cambias con AT+SAPBR y vuelves a mirar que configuración hay no se altera, son como dos procedimientos para configurarla pero que ninguno me permite conectarme.
En el caso de que esté configurada desde el móvil tampoco parece ser que se conecte.

Hola
Si el comando cops? te da resultado negativo al igual que el csq, el sim800 esta mal. Yo tengo unos 20 SIM900 y alguno ha ido de vuelta a fábrica. Lo mas simple para saberlo es ejecutar estos 2 comandos y nada mas. Si no encuentra red (gsm normal) tiene algún fallo interno. Antes asegúrate que en un móvil tiene cobertura.

No se si el sim800l dispone de botón reset, si es así resetealo y haz la última prueba antes de devolverlo.
He buscado y he encontrado esta pagina donde dan algunos consejos sobre SIM800L. Suerte

Saludos

Quizás intente actualizar el firmware. No obstante me he comprado un esp32 con módulo sim800 incorporado y solo conectarlo a la corriente me conecta. Así que muy probablemente estés en lo cierto. Muchas fracias por todo compi.

Una pregunta más, se supone que si ya se ha conectado a GPRS desde un móvil...¿Se conecta automáticamente en el sim800l?

No entiendo la pregunta.
¿Quieres decir que si la sim se conecta sin problemas desde un móvil debería conectarse sin problemas en el Sim800? si, claro, pin y tonterías aparte

Saludos

El caso es que he comprado un nuevo módulo sim800l y soy incapaz de que se conecte. No entiendo porqué.

es raro que te fallen 2 módulos. Mira a ver la antena.
Ya te he dicho que no conozco el sim800l. Yo tengo un montón de SIM900 y si le pones una sim sin pin y pulsas el reset, sin hacer nada mas, los leds te indican si está o no conectado.
Si has revisado el link que te pasé y no hay manera, deberás esperar a que alguien experto en el SIM800L te aconseje.

Saludos