SIM900 y Arduino Uno

Hola, implementé el SIM900 en mi proyecto y ha salido un par de datos curiosos que me gustaría compartir.

El SIM se alimenta directamente del Arduino y logra dar respuesta al comando AT y responder OK.

En mi primer día con el módulo surgió el problema de la conectividad para mi, tuve problemas en que el LED de status agarre señal pero después de mil intentos se logró y de esta manera se pudo hacer llamadas mediante el comando ATD y el número a llamar.

Ayer en mi segundo día no hubo manera de conseguir señal y que el LED de status se ponga estable, traté de 1000 maneras incluso saliendo a la puerta de la casa con la laptop (según lo que pude leer dice que puede tener dificultades en conectarse en interiores). Bueno como segundo día puedo comentar que no se consiguió conexión jamás, por otro lado encontré adicionalmente que las antenas que vienen por defecto no son muy buenas y que recomiendan hacer el cambio de ellas, el problema radica en que no especifican el nombre de las antenas por lo tanto es un poco difícil saber donde conseguirlas.

Dejo un link del video que empleé de tutorial ya que es el mismo módulo que utilicé. Si alguien me dice por favor como se llama la antena por la que se reemplaza en el video (ya que ni bien la conecta agarra señal al instante) y el comando AT que permite verificar la conexión para con el código de error poder encontrar la solución en internet y buscar posibles soluciones se lo agradecería bastante.

Gracias!

El SIM se alimenta directamente del Arduino y logra dar respuesta al comando AT y responder OK.

El SIM900 requiere 2A para transmitir.
Alegrate de no quemar el ARduino. Estas advertido!!

Y tu eres el mismo que recomienda NO comprar el SIM800L y hay otro hilo donde alguien lo ha usado sin problemas, lo que no signifca que tu los tuvieras, porque probaste de todo.

Bueno cualquier SIM consume mucha corrente durante TX y RX asi que tenlo en cuenta.

Hola de nuevo y gracias otra vez! (ya que me apoyaste con lo del SIM800L).
Entonces fuente de alimentación externa de 2A, y para no arruinarlo: ¿Voltaje para alimentar el SIM900?

Si soy el de la SIM800L y gracias por toda la ayuda que me diste en el proceso. Lástima que la fuente que emplee al final diera error y quemara la SIM800 :frowning:

Y como paso eso?
Si no puedes darle mas de 4.4V no?

Como en varias partes decía que el voltaje debía ser exacto a los 4V y con pilas y adaptadores de pared era imposible conseguí prestada una fuente regulable. Gradué la fuente a 3.8V y medí cuanto salía con un voltímetro; en el voltímetro salió le valor de 4V por lo que procedí a hacer las conexiones ya que se encontraban ambos valores en los rangos recomendados.

Cuando conecté el último cable para que la corriente pase por toda la instalación en la fuente se alteraron los números solos (saliendo un valor mayor a 2 dígitos, pero fue tan rápido que no pude ver el número) y luego cayeron a 1.2V y salió olor a quemado con un chispa en el lugar donde puse la ultima conexión.

Después la fuente no se pudo regular más por lo que supongo que la fuente estaba defectuosa... luego trate de conectar a 3.3 y a 5V pero ya jamás volvieron a encender las luces.

Esta información creo que debería ser el cierre del post que inicié en la SIM800L.

Disculpa, ahora el SIM900 es a 2A, ¿pero el voltaje?

¿Esta información es correcta sobre el SIM900?
Aquí dice que su voltaje de operación es entre 9V y 20V, eso quiere decir que ¿puedo ponerle una fuente de 12V conectada a la pared y que no tendré problemas?
Este es el link que encontré con algunas especificaciones que me gustaría saber si son correctas.

http://www.mactronica.com.co/modulo-gsm-gprs-sim900-con-antena-43990919xJM

Bueno, comento lo último.
Cambié el chip del operador y todo anda al 100%. La alimentación que le di al final fue con 12V al módulo con 2A y sin problemas (el vendedor me recomendó emplear 12V).
El Arduino Uno conectado a la PC y a una fuente externa trabaja perfecto en ambas formas. Lo que hice si por precaución fue colocar un ventilador de PC de 12V debajo para que enfríe todo el sistema (alimentado desde otro punto de corriente).

Conclusiones:

  • Alimentar externamente el módulo a 12V y 2A.
  • Colocar un ventilador de 12V de PC debajo para evitar que caliente.
  • Cambiar de chip de la empresa telefónica, en mi caso en Perú, la empresa que si funciona bien y sin ningún problema es Claro, el chip de Entel da problemas de conexión (no probé utilizar un chip Movistar).

Muchas gracias surbyte por tu ayuda y paciencia tanto en este módulo SIM900 como en el módulo SIM800L.

Perdona por no responderte, estuve enfermo y recién tengo ganas de responder.

Evidenteme has sido capaz de manejarte bien por tu cuenta y eso es lo mas rescatable de toda la experiencia.
Aprender a solucionar las cosas uno mismo.

Te aconsejo siempre leer bien antes de comprar. Mira que compras, como se alimenta y que vas a esperar de ello. Incluso busca todo lo que necesites y la experiencia de otros usando el módulo que te interesa.
Te ahorrará muchos dolores de cabeza.

Te felicito por el éxito conseguido.