SLOEBER Not quite ready for Prime Time

Sloeber is a great tool if you know the limitations. I have had a few compile issues with it not recognizing problems. For example, in a recent project I used the StepperDriver-Master library. I instantiated a member of the A4988 class and did an include of A4988.h. Then deleted the #include A4988.h and no errors were issued.

I have had several similiar issuse with this plugin to Eclipse, so not really sure its worth the effort. But it does offer some really nice capabilities, price is way to high for the problems it currently has however. Stick with the Arduino IDE.

I have been using Sloeber and it has worked fine for my situation. For me, there is a considerable advantage to using Eclipse instead of using the Arduino IDE.

Others may have other opinions.

I've encounter some flakey behavior with Sloeber every now and then. But, after using it, I now find it impossible to do serious development in the Arduino IDE.

the C++ indexer is independent from the Arduino builder. the indexer sometime fails to catch up with code changes. but this is a problem of the Eclipse C++ indexer, not Sloeber. if you use Verify, the warnings and errors are taken from compiler output

I agree with most everyone, sloeber and eclipse is a powerful tool. Having the ability to search the library to see how functions are written is a great help when debugging programs.

My latest problem is that it will not pickup a library I need. I downloaded the StepperDriver-master library from Github because it contains the A4988 header files I wanted to use. It was there for a while then dissappeared. Now it refuses to find the library no mater what I do. I have never liked applications that hide this kind of behavior from the user. There is no indication of why it will not pickup the library in Library Manager and nothing I can fine in the literature to give me any indications of what is going on. I am pretty sure its an Eclipse problem more than a Sloeber issue. I solved this problem by adding the library to my Arduino library and adding the Arduino path to my private library path in SLOEBER. Strange to me that the Arduino library folder works but another folder I wanted to use does not.

The other issues I have found is that if I am making a lot of uploads to the UNO sometimes, and very frequently, the new code is not uploaded even though it seems to be. Here is an example, I added some code to a sketch to check out an oled I wanted to use. Seemed to work OK, so I commented the applicable sections out and uploaded the code again. The oled continued to function even though the code had been deleted and new code uploaded. I had to upload BLINK and then upload the new code to purge the code from the arduino. Very strange behavior and if you are not aware of that kind of behavior it could be very frustrating when you make a change to code and it doesn't seem to make any difference to your project.

Having the ability to search the library to see how functions are written is a great help when debugging programs.

You got that without Eclipse. They're just text files with the code.

Most of the problems you are describing just sound like a new user who isn't used to all the quirks of Eclipse yet.

Watch your console when you upload. With Sloeber you are going to see the whole output from AVRDude. You may see a bunch of stuff that looks like it is working and then an error at the very end.

I had all the same sorts of issues when I first started out with it. Once you get used to how things happen without the Arduino IDE doing it for you you'll end up liking it a lot better. But there can be a bit of a learning curve getting used to how it is done in Eclipse.

I have never liked applications that hide this kind of behavior from the user.

That's just it. Eclipse doesn't hide any of that from you. It's all under your control. And as a consequence, you gotta set it all up right or it doesn't work. The only thing Eclipse did was hide the menu option or the button you want.


Many thanks. Actually I started using Eclipse many years ago when it was first introduced. I was programming commercially for Compaq at the time and we didn't have an IDE for C++. I started using Eclipse and found it a very powerful tool. The learning curve is pretty steep, but once you have it down pat, all is wonderful.

By seeing all code, I meant having the ability to see all code is a singel location without having to keep changing applications. That is one advantage Eclipse has always had, I can see and integrate java, c, html etc into the same project.

Anyway, most of the issues I have encountered seem unique to the Arduino plugin, not to Eclipse proper. For example, I never had an issue with libraries before in the C++ or Java Perspective. Of course I haven't actually coded comercially in a very long time and maybe Eclipse has changed, I am just doing this as a hobby now.

I like Eclipse and the Arduino plugin. It has progressed from the original plugin I used a few years back but I think it still has some issues that would vastly improve the useability of the IDE.