SoftwareSerial headaches. Need your 2 cents. I'm talking to the new ESP8266

Hello: any input would help a lot. I’m stressing to try to do a simple webserver for my daughters science project.

I have Arduino.exe 1.0.6, R2 and R3 Unos. I transmit on 2 and receive on 3.

My problem is that I get garbage characters while talking to ESP8266 (the new 9600 baud) modules using both a R2 and R3 Uno. I am using a Voltage divider. If I send a long command, e.g. AT+CPSTART… then I always some garbage characters back. BUT if I tee the ESP8266 Tx line into a USB-TTL device I never get garbage characters in the putty.exe terminal’s window.

I put delays in the Tx part, no help. I shouldn’t receive more than 64 bytes at a time, so I don’t know what is going on.

I tried a loopback test by writing characters on pin 2 and receiving them on 3. But I don’t get a single character?

I noticed also if I send tons of data to ESP chip (send AT, wait for OK), it works better if my hardware serial port is 1200 not 9600?

Have you tried communicating with the module using the arduino serial monitor?