[Solved] error with the library "IRREMOTE"

I am doing a new code with the IR receiver module and the Elegoo control that comes with it. At the first

time that I used the library in ARDUINO CREATE everything was right, the program did the compilation and

umploaded the code. The problems was that at the next day I made other code but at the moment of the

copilation it says, "IRemote.h: No such file or directory". Also i tryed to copile with the first code that

worked, but it shows the same error. My other obtion was compile one of the IRREMOTE library's examples,

but it shows the same error.

I don't know what to do, please help.

It sounds like the lib might have been corrupted or that another non related lib with the same name etc may be confusing things.

If its a library you uploaded then you could delete it and upload the original to see if that fixes it or maybe try it on the desktop IDE.

Could you share the link to your CREATE sketch please so that somebody might try it themselves to see what you are facing an also a link to the original lib source too.

While you certainly do need to spell and capitalize the file name correctly (as you have failed to do here), there seems to be something wrong with Arduino Web Editor.

I can confirm that the following sketch:

#include <IRremote.h>
void setup() {}
void loop() {}

gives the error:

/tmp/937910289/sketch_sep15a/sketch_sep15a.ino:1:22: fatal error: IRremote.h: No such file or directory

compilation terminated.

exit status 1

IRremote is one of the Arduino Library Manager libraries and is shown in the Library Manager search on the Arduino Web Editor.

and it’s not only the Library Manager libraries. Even the “Built in” libraries included with the standard IDE are missing:

// Ethernet - Version: Latest 
#include <Ethernet.h>
void setup() {}
void loop() {}
/tmp/278311039/sketch_sep15a/sketch_sep15a.ino:2:22: fatal error: Ethernet.h: No such file or directory

compilation terminated.

exit status 1

The only libraries you can include are the ones bundled with the hardware core (SPI, EEPROM, Wire, SoftwareSerial, etc.)

@ballscrewbob, can you reproduce this issue?

Hi Pert

I can indeed confirm some form of issue

Added the requisite lib from lib manager.
On calling up one of the examples I just get a "loading source" message.

There are a lot of 404 errors in the chrome console which would indicate a server problem.
Unlike the forum I don't think it has a self restart fallback.

Would you like to throw it up on GIT (I tend to make a hash of it)
I will put it on SLACK.

EDIT
Same with other sketches that have a lib dependency regardless of lib source they are failing here.

ballscrewbob:
Would you like to throw it up on GIT (I tend to make a hash of it)

I will do so. I don't really like reporting issues there. Partly because I never use Arduino Web Editor so I'm not sure if I'm doing something wrong. Also because it's not very appropriate to issues not specific to the Create Agent. I've never been able to get a definitive answer from the developers on where the issues should be reported. They do a good job of responding to posts here but the forum doesn't seem well suited to tracking bugs. I remember being told that there is a private issue tracker for Arduino Web Editor. I'm surprised you don't have access to that one ballscrewbob.

The real repo is private and I dont have access either.
Agent is usually the best place for them.

There was talk if a different tracker and some very limited access but not seen anything for it.

I left a note on slack but given the time difference it will be the early hours of the morning before they see it (still good IMHO)

Also referred it to this thread.

Here is my report for this issue:

The problem should be fixed now, thanks for reporting it