SOLVED Fingerprint scanner + arduino pro mini

Hi everybody,

I am having an issue with my FPS (https://www.sparkfun.com/products/13007) : I can’t control it with my Arduino Pro Mini 3.3V.

I connected directly to the computer (through FTDI) to use the SDK Demo, it worked fine, but back on the Arduino, nothing at all except that on the serial monitor:
"FPS - Open
FPS - SEND: “55 AA 01 00 00 00 00 00 01 00 01 01”

Here is what I have tried so far:

  • switch TX/RX (because from a website to another they are not the same…)
  • input voltage 3.3V, 3.7V, 5V
  • with / without resistors
  • change baudrate ( 9600 / 115200)

and my code:

#include “FPS_GT511C1R.h”
#include “SoftwareSerial.h”

FPS_GT511C1R fps(1, 0);

void setup()
{
Serial.begin(9600);
fps.UseSerialDebug = true; // so you can see the messages in the serial debug screen
fps.
Open();
}

void loop()
{
// FPS Blink LED Test
fps.SetLED(true); // turn on the LED inside the fps
delay(1000);
fps.SetLED(false);// turn off the LED inside the fps
delay(1000);
}

Any help please ?

I'm not sure, but first try deleting the spaces between fps. and open();. Then, try changing FPS_GT511C1R fps(1, 0); to FPS_GT511C1R fps(4, 5);. That is how it is on the original code. Or, if you can't do that, change it to FPS_GT511C1R fps(Non-PWM pin, PWM pin); no matter what

Hi and thanks for the reply,

I tried that…but still nothing the LED is off…

Hey,

I found the solution : no resistor at all between the FPS and the arduino. It works just fine like this and it still works as of today. Seems that sparkfun change the FPS in order to be directly connected to the arduino.