[SOLVED] Just built Arduino Severino (S3v3) and can't upload to it

I just built myself one of these Arduinos: http://arduino.cc/en/Main/ArduinoBoardSerialSingleSided3

Thanks to the instructions from BillO in this thread: http://arduino.cc/forum/index.php/topic,70148.0.html I got my bootloader written and since the L\Pin13 LED flashes I assume it is running OK.

I am running Windows XP and Arduino software v1.0 (and used bootloaders which came with it)

The problem is that when I try to upload anything (via standard serial port) I get this message: avrdude: stk500_getsync(): not in sync: resp=0x00

Just before I get this message, the Rx LED flashes 3 times.

I have tried running the loopback test which passes.

I have tried both NG and Diecimila firmware and the result when trying to upload anything is the same.

Can anyone give some advice?

Both jumpers have to be plugged in the same position as they are shown in your photo.

You could try pressing the RESET button around a second before avrdude starts uploading the hex file to arduino board. More or less when a the message "binary sketch size..." appears.

mariobac:
Both jumpers have to be plugged in the same position as they are shown in your photo.

Well of course they are, the one in the photo is mine :wink:

It looks like it was a software\configuration issue, though.

I tested the Arduino on a different machine and it worked just fine.

Logically this would make me suspect the serial port on the PC, but if it were faulty, why would the Arduino Loop-back test pass (which must run through the level shifter circuitry) - but uploading not work? Seems very odd.

I installed an old ISA-Based Serial port card to the machine and in doing so had to disable the onboard serial ports in the BIOS. The Arduino worked just fine on the ISA card.

It was then I had the clever idea to test the onboard serial port with another device, so, after removing the old ISA serial card I tested an old 56k Modem on the onboard serial port and it worked just fine.

On a 'just for fun' I then re-tried the Arduino on the onboard serial port and it worked just fine!

As far as I know, all the settings such as Baud rate etc were correct before, but it seems that the act of disabling and re-enabling the serial port in BIOS and WIndows re-installing the serial port has made it start working with the Arduino. I still don't know why, but at this point I don't really care. As long as it keeps working, I'm happy! :grin:

Nice work!
Always wanted to build one myself but haven’t got the right tools yet.

Glad your problem is solved and I should get my hands wet some day.

Thanks for sharing :slight_smile:

I bought several of the bare serial boards from mouser and components to populate them from dipmicro.com,
will get around to assembling one of these days - assuming I still have parts, they seem to be absorbed into other projects as I go!

It's pretty easy to do, if you know how to solder and you've got something to program your blank AVR with, you're away laughing.
(Assuming you have no issues with your serial port, anyway!)

I think if I were to build one again, I would use a MAX232 level shifter IC instead of the basic 2-transistor circuit. The MAX232 has some advantages and is cheap, so there is not really any good reason to use the other design.

I don't know if there are any single-sided and easily built Arduinos with this IC (Have seen double-sided but no good for home build!) so perhaps I will try to make a single-sided layout myself...

Anyone who is interested, I just finished a preliminary layout for a Severino-Based Design with MAX232 and also space for a 3.3v regulator, since the original did not include it, and it seems to be a feature on newer Arduinos. If you don’t want\need 3.3v you can simply leave it out.

Design based on one I found here: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1204721597/all by “purgedsoul”

I also made some small changes, like putting the 5v regulator’s decoupling capacitors actually next to the regulator where they should be, and leaving room for the 100 microfarad electrolytic capacitors to lie down as getting short ones can be quite a pain.

3D render shows the general gist of it.

Didn’t use Eagle (although tried to) but couldn’t add any components, grid spacing was all FUBAR, nothing would work, not sure how to fix it as I don’t use Eagle much, so if anyone wants the files they’ll have to put up with KiCAD. Haven’t tested the design but it should work.