[SOLVED] MKR1010 port not found

I know it’s a commun problem , but I still can’t fix the problem .
My MKR1010 was working great on my ubuntu 20 but now the arduino ide doesn’t find/detect the port .
(before it was the /dev/ACM0)
This really disturbs me so much because I can’t continue my work if even the port is not detected .
Any reply is welcome
Thanks

The tricky thing about the boards with native USB functionality like your board is that the USB code that creates the CDC serial port is running on the same microcontroller as your sketch. This means your sketch code can break the USB code, or stop it from running, resulting in no port for the board.

Fortunately, there is an easy way to recover from this situation:

  • Press and release the reset button on your board quickly twice. You should now see the LED on the board pulsing, which means the bootloader is running. The double press causes the bootloader to run indefinitely (until the board is reset, powered off, or an upload is done), which means you don't need to get the timing of the reset just right.
  • Select the port of your board from the Tools > Port menu. The port number may be different when the bootloader is running so don't assume you already have the correct port selected.
  • Start an upload in the Arduino IDE.

The upload should now finish successfully. After this, you should be able to go back to doing normal uploads without needing to press the reset button. If you still need to do the reset trick to do uploads after this, the problem may be caused by your code. You can verify this by uploading a simple sketch like File > Examples > 01.Basics > BareMinimum.

Thanks for bringing life to my day … WORKED

You're welcome. I'm glad to hear it's working now. Enjoy!
Per