[Solved] Nano with W5100 Shield for Mega

Hi, I have an Arduino Nano and a W5100 Ethernet Shield for an Arduino Mega 2560. When the shield is attached to the Mega, everything workks just fine, now I connected it to my Nano, using the SPI pins from the ICSP-header on the shield and pins 10 to 13 on the nano as shown in the code examples. I am powering the setup with an external power supply and an 7805 regulator to nearly 5V.
The problem is that everytime I open the serial console it shows (for the Ethernet->WebServer example)

Ethernet WebServer Example
Ethernet shield was not found. Sorry, can't run without hardware. :frowning:

I am running out of ideas, can you guys help me?

Okay so I finally figured out what went wrong.
In order for the shield to work you have to connect the RXD and TXD pins from the arduino to the shield as well as the known pins 4 and 10 as CS/SS for the sd card reader or the ethernet chip, the ICSP header. YOU DON'T NEED TO CONNECT PINS 11 12 AND 13 FROM THE ARDUINO NANO TO THE SHIELD! I dont know why nobody mentioned this anywhere on the internet but hey, here you go, hope this will help someone in the future

a link would be good... there are so many of those around

This type of shield (I got it from someone else and it has no manufacturer printed on it):

and a generic Mega2560 clone from china

die Pinout ist hier beschrieben
MISO, MOSI usw. befinden sich auf einer MEGA nicht an derselben Stelle wie auf einer UNO

EDIT:
-- oops
the pinout is described here, you don't connect a MEGA in the same way as the UNO if you use the side pins.

Alles gut schreibe Forumbeiträge immer auf Englisch wegen der größeren Zielgruppe :wink:

All the instructions I've read online said to connect the pins from the shield like you would connect them to an Uno and I thought as the shield worked on the Mega even with the SPI pins on pin 53 etc not connected, but as you see on the page you linked it doesn't say anything about connecting rx/tx either.

got confused after reading the German link you shared on Amazon :wink:

I'm also confused what pins you ended up connecting. Just Rx and Tx won't do it (and I'm not sure why you would need them)

Tbh I don't have any idea why I needed to connect them but without them it didnt worked

What else did you connect?

GND, VCC (5V), Pins 4 and 10 and the ICSP header.
I disconnected RX and TX now and for whatever reason it works now also without them... I HATE IT

Ok - that makes sense

The fact that you need Tx and Rx was Weird unless the library was something special which seems low probability…

May be bad connexions?

I firstly had a nano where on pin 11 the solderpad was ripped of but I changed that one to a brand new freshly soldered one and it still didnt work, on the 3rd nano (again another brand new one) it worked and as I then connected rx and tx I thought that it was the problem

Also tried the same setup on a Nano but not still working... while it works fine when hooked up into an Arduino Mega 2560...