[SOLVED] SNMPGet returns empty response with UIP_Agentuino

Hello,

I am currently working on implementing SNMP in my Arduino project and downloaded the version of Agentuino that supports the UIPEthernet library, since this is the one I need. This is where I got it all from:

When I try to get a value with my software (written in Lazarus with Ararat synapse if that's of any importance) it returns me an empty string. I know that the SNMPGet got through, because I have set up different responses for when it doesn't. It doesn't matter what OID from the example Agent given I use, I even set up my own sensor OID and still get an empty string as response.

The port is 161 for the both ends of the communication.
The community is the same for both.
The connection is established, but somehow the value never gets through.

I've worked a lot with SNMP and this is the first time I get such a response. I am sure there is something I am doing wrong on the Arduino side, but I can't figure out what.

AgentPlus.ino (10.7 KB)

Replacing strcmop_P with strcmp at the section with OID comparison solved the problem. Now this example gives me data reliably.

Serves me right for not knowing the C commands well enough....