Starter kit 101

maybe anyone could help out what seems to be the problem :slight_smile:

Arduino: 1.8.14 Hourly Build 2021/04/30 05:33 (Windows 10), Board: “NodeMCU 1.0 (ESP-12E Module), 80 MHz, Flash, Legacy (new can return nullptr), All SSL ciphers (most compatible), 4MB (FS:2MB OTA:~1019KB), 2, v2 Lower Memory, Disabled, None, Only Sketch, 115200”

Executable segment sizes:

IROM : 228672 - code in flash (default or ICACHE_FLASH_ATTR)

IRAM : 26756 / 32768 - code in IRAM (ICACHE_RAM_ATTR, ISRs…)

DATA : 1248 ) - initialized variables (global, static) in RAM/HEAP

RODATA : 688 ) / 81920 - constants (global, static) in RAM/HEAP

BSS : 24880 ) - zeroed variables (global, static) in RAM/HEAP

Sketch uses 257364 bytes (24%) of program storage space. Maximum is 1044464 bytes.

Global variables use 26816 bytes (32%) of dynamic memory, leaving 55104 bytes for local variables. Maximum is 81920 bytes.

esptool.py v2.8

Serial port COM4

Traceback (most recent call last):

File “C:\Users\Surface\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.7.4/tools/upload.py”, line 65, in

esptool.main(cmdline)

File “C:/Users/Surface/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.4/tools/esptool\esptool.py”, line 2889, in main

esp = chip_class(each_port, initial_baud, args.trace)

File “C:/Users/Surface/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.4/tools/esptool\esptool.py”, line 237, in init

self._port = serial.serial_for_url(port)

File “C:/Users/Surface/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.4/tools/pyserial\serial_init_.py”, line 88, in serial_for_url

instance.open()

File “C:/Users/Surface/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.7.4/tools/pyserial\serial\serialwin32.py”, line 62, in open

raise SerialException("could not open port {!r}: {!r}".format(self.portstr, ctypes.WinError()))

serial.serialutil.SerialException: could not open port ‘COM4’: FileNotFoundError(2, ‘The system cannot find the file specified.’, None, 2)

serial.serialutil.SerialException: could not open port ‘COM4’: FileNotFoundError(2, ‘The system cannot find the file specified.’, None, 2)

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

Make sure you have selected the port of your Arduino board from the Arduino IDE’s Tools > Port menu.

  1. Unplug your Arduino board from the computer.
  2. Select Tools > Port from the Arduino IDE’s menus.
  3. Note the ports, if any, listed in the menu.
  4. Close the Tools menu. The ports list is only updated when the Tools menu is re-opened, so this step is essential.
  5. Plug your Arduino board into the computer.
  6. Select Tools > Port from the Arduino IDE’s menus. - The new port listed in the menu is your Arduino board.

Thanks, maybe you can help out with this also ?

Arduino: 1.8.14 Hourly Build 2021/04/30 05:33 (Windows 10), Board: “Arduino Uno”

Sketch uses 3094 bytes (9%) of program storage space. Maximum is 32256 bytes.

Global variables use 216 bytes (10%) of dynamic memory, leaving 1832 bytes for local variables. Maximum is 2048 bytes.

An error occurred while uploading the sketch

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x30

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x20

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x30

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x20

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x30

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x20

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x30

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x20

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x30

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x20

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.