Stepper problems

Hey there. I'm decently new with arduino's and such and for the past many weeks I've been trying to get a Nema 17 motor to drive with all kinds of different stepper drivers with limited success. I've tried the EasyDriver and the A4988 all thinking that I have been breaking them. However I got my hands on the 'SparkFun ProDriver - Stepper Motor Driver (TC78H670FTG)' and got it set up to their hardware guide, and using their example code and the motor still doesn't turn.

Ignore my ghetto setup

What is the picture supposed to tell us?
What are you using to power the stepper motor and what are you using to power the Arduino? Are all the grounds connected?

Hey, I'm using a 12v power supply. And the arduino was just being usb powered. As far as I know the ground is connected from the stepper board to the arduino. Not sure if anything else needs to be done.

Did you measure the resistance of the ground wires from one device to the next?

I did not. Not fully sure how to do that, however I did order a multimeter that I'm waiting to arrive.

I found out the issue, even though I did have a 12v power supply I didn't have enough amps to power the motor. Pretty unforturnate to figure out after buying like 6 different drivers xD

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.