Stuck on uploading. Tx lights up and serial monitor spews data indefinitely.

Hello, I feel guilty about creating a new topic, but I’ve looked everywhere and haven’t found an answer yet.

When I plug in my Arduino with the USB connection it uses COM6 and the L lights up once and turns off, and the ON led is always on.

My problem is that I get stuck when uploading a sketch. When I try to upload, the Tx led lights up (not blinking; completely lit) and it gets stuck on “Uploading…”. If I cancel it and start again, I get the error:

processing.app.SerialException: Serial port ‘COM6’ already in use. Try quiting any programs that may be using it.

Alternatively, if I plug in the Arduino and open the serial monitor from the IDE, the Tx lights up and I get a constant stream of data, that corresponds to the voltage in pin A0 (in a range from 0 to 256) (see attachment)

I remember I did a project once where I was measuring the voltage from A0 and did something accordingly. I didn’t use the Arduino for a long time (5-6 months) and suddenly I can’t upload anything anymore and I think it’s stuck on the program I made a long time ago.

Any help will be greatly appreciated!

asdasd.JPG

go to tools/port in the IDE if it shows a tick and COM6 try plugging into another port and see if it changes. You will have to come out and go back into tools/port to see the change.

So when it’s connected to my 1st USB port, it shows up in COM6 (with a tick) like in the attached image. When I disconnect and connect into another USB port, and close and open the IDE again, it’s still like in the image, with COM6 ticked.

it looks like you have a serial connection problem. do you get two audible notes if you unplug and replug the arduino? is the tools/port greyed out when you don't have the arduino plugged in? if so does arduino uno have a dot at the side of it in tools/board?

I think I have had the same issue, and managed to solve it. Hopefully it is the same issue you are experiencing.

Due to my Arduino inexperience, I was creating a sketch and was using digital pins 0 (RX) and 1 (TX) in my sketch as outputs. I dont understand why, maybe someone can explain, but I could not upload any sketches to my arduino. It was stuck in the upload state, about 80% complete, no matter what sketch I tried to upload.

I changed these pins to 2 and 3 instead, and this solved the problem.

Hopefully that helps!

MG

Having the same problem I came here and this helped me find the solution, which is remarkably simple:

pins 1 and 2 are rx and tx for the arduino programmer. When you are using those pins for whatever reason, the attachment you have on it likely was interfering with the transmission. You can still use those pins, you just can't program them with stuff that will drain the line connected to the pins!

I had a similar problem a while ago. I just created a bare sketch with an empty setup and loop function then hit the upload button. Just before the status in the ide changed to uploading I hit the reset button on the arduino. It took about 3 attempts to get my timing right but it worked and it's been OK ever since.