Arduino UNO Serial port busy. Working yesterday?

Hey All

My Arduino UNO has been working perfectly since I bought it a few weeks back.

However today, I plugged it in again to upload my latest sketches and see if it works, except now, when I try and upload, or use the serial monitor it is saying that the com port is busy!

I have restarted the IDE, reset the arduino, restarted my machine and changed USB port, all to no avail!

Any thoughts?

Thanks

Anton

Post exact text of error message so we're all on the same page.

Have you recently installed anything that uses the serial port and might be assuming any serial port is something it should be trying to use?

I installed Adobe PDF reader? I wouldn't imagine that would cause the issue would it?

I shall uninstall and try again, just in case!

Which part of "post exact text of error message" you didn't get....

But did you select the right COM port? There is no guarantee the Uno will get the same number each time...

"Error opening serial port 'COM3'. (Port busy)"

Is the error page.

I know its right COM port as I have checked in device manager, and I can also get the Board info when in the IDE

What Septillion is asking for is the complete output from the lower section of the IDE when you try to upload.

When an error occurs the bar above the console should turn orange/red and a button should appear saying “Copy error messages”

Hit that button and paste the resulting information in here.
But PLEASE endure you use code tags from the toolbar in here ( </> )

AntonZdz: and I can also get the Board info when in the IDE

No you don't. That "board info" simply is whatever you have selected.

But then I would restart the PC. Some program is trying to use that com port for whatever reason. And only one program at a time can use a COM port. Some blue tooth crap tries to do that.

You could assign a new com port number to the Arduino in the hope the program will not start using the new port.

I have restarted the machine a few times, and tried changing the COM port as well to no joy.

Error message below for upload.

Arduino: 1.6.12 (Windows 7), Board: "Arduino/Genuino Uno"

Sketch uses 7,108 bytes (22%) of program storage space. Maximum is 32,256 bytes.
Global variables use 633 bytes (30%) of dynamic memory, leaving 1,415 bytes for local variables. Maximum is 2,048 bytes.
avrdude: ser_open(): can't open device "\\.\COM3": Insufficient system resources exist to complete the requested service.


Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Thanks All

Guys and Gals

Thanks for all your help, but its sorted now.

I changed the COM port once again, gave it a restart and it magically worked again, despite me having already tried this.

Thanks for the input, and I shall try to remember to use the copy error message button in future, rather than just copy the output I see!

Thanks All

"Insufficient system resources exist to complete the requested service." Thats the real clue.

Drop that into Google as it looks like an Issue with either your computer hardware or software.

Septillion hit it right on I think. Looks like you have issues with other software using the serial ports. (or inadequate hardware)

In my case, on win 10 and Arduino DUE, serial port was "occupied" by Bluetooth settings. I had to turn off Bluetooth on my laptop to have it free again.

Hi I have the same problem "SERIAL PORT BUSY" since I start use PLX DAQ to export to excel data from 1 sensor .

Any idea about the solution

Thanks

@dascastelhano

You should probably have started a new topic and included more information. There is a thread specific to PLX DAQ also btw.

Remember that unless you are using softserial or similar only one COM connection can be made to the Arduino.

Bob.

I had this issue due to faulty computer charger for my laptop. Unpluggin it and restarting the web ide page or desktop app fixed it. I have multiple chargers and it runs just fine with the other ones.