TCS3200 problematiche led e pin

Salve a tutti, ho acquistato un sensore di colore TCS3200 (Sensore Colore con TCS3200), ma nonostante abbia provato a collegarlo al mio Arduino Uno in più modi con i relativi sketch (come: https://howtomechatronics.com/tutorials/arduino/arduino-color-sensing-tutorial-tcs230-tcs3200-color-sensor/ e https://www.luisllamas.es/medir-color-arduino-colorimetro-tcs3200/) si attiva soltanto un led su 4 presenti sulla scheda. Ho notato che se provo ad eccitare i singoli led direttamente da un alimentatore ATX con 5V, questi o si accendono o, a seconda della polarità dei cavetti dall'ATX, fanno accendere altri led.
Inoltre non sono riuscito a capire come mai il pin LED a volte venga collegato e a volte no e a cosa serva (alimentazione led?). Spero di non esser stato troppo confuso! :slight_smile:
G.

ciao :slight_smile:

consiglio non dare mai i 5 V ad un led... se no o bruci.... massimo 1,5 v per fare dei test....

ti allego un link che può essere utile a capire anche il pin LED come puoi capire dalo schema nella pagina :slight_smile:

MD

MatteoDerrico:
consiglio non dare mai i 5 V ad un led... se no o bruci.... massimo 1,5 v per fare dei test....

Perfavore non diciamo cose errate (per essere gentile) ...
... per i LED conta la corrente che ci fai scorrere all'interno, NON la tensione con cui alimenti il tutto. Con 1.5V ... c'è anche la probabilità che un LED non si accenda nemmeno, visto che potrebbe essere un valore inferire alla caduta di tensione introdotta dal LED stesso.

Occorre guardare il datasheet, vedere la corrente suggerita dal produttore, la caduta di tensione e, con detti valori, calcolare la resistenza da mette in serie in funzione della tensione a cui lo si alimenta !

Guglielmo

io ho inteso che lui alimentasse il led direttamente con dei fili sul anodo e catodo del LED... dal momento che ha dichiarato che alimenta senza considerare la polarizzazione :

Jack646:
Ho notato che se provo ad eccitare i singoli led direttamente da un alimentatore ATX con 5V, questi o si accendono o, a seconda della polarità dei cavetti dall'ATX, fanno accendere altri led.

se ad un led di 5mm si danno 5V polarizzati inversamente puoi bruciare il componente... ed essendo saldato su PCB ci si crea lavoro inutile... :slight_smile:

provare per credere :slight_smile:

MD

MatteoDerrico:
... se ad un led di 5mm si danno 5V polarizzati inversamente puoi bruciare il componente...

... quella è chiaramente indicata sul datasheet come "Reverse voltage" e, come tutti i parametri riportati nel datasheet, va rispettata.

Se non si rispetta uno dei parametri e si supera il valore massimo consentito .. è piuttosto ovvio che si danneggi il componente!

Guglielmo

appunto per quello ho messo in guardia Jack646...
perciò penso e spero di non aver detto cosa errata (stando gentile) :):slight_smile:

avendo letto ciò che ha scritto :slight_smile:

MD

@MatteoDerrico
Il consiglio di 1,5V é errato.
Se dai 1,5V a un LED, secondo del tipo o si brucia o si illumina o non si illumina (rispettivamente Ir, rosso, Blu e bianco).

Ciao Uwe

MatteoDerrico:
ciao :slight_smile:

consiglio non dare mai i 5 V ad un led... se no o bruci.... massimo 1,5 v per fare dei test....

ti allego un link che può essere utile a capire anche il pin LED come puoi capire dalo schema nella pagina :slight_smile:

MD

Grazie a tutti! Ho confrontato lo schema con il circuito stampato del sensore. E' probabile che i 3 restanti led non si accendessero perchè sono stati per errore montati invertiti? Oltretutto, in un momento di stanchezza, ho per sbaglio invertito l'alimentazione nel sensore (ho messo i 5V sul GND) e i 3 led che fino a prima erano rimasti spenti si sono accesi (purtroppo me ne sono accorto dopo dell'inversione di polarità e il risultato è stato l'aver bruciato dopo 10 min circa un condensatore... l'inizio non è stato dei migliori!).

A proposito del pin LED: qui è impostato come OUTPUT (Let's Make Robots - RobotShop Community) in modo da far lampeggiare i led. Potrebbe essere che il pin viene utilizzato proprio per fornire alla base del transistor NPN un segnale LOW per spegnere i led?

G.