The forum is kicking me to forum.arduino.cc

The forum is causing me a lot of trouble, and it is getting worse. I can almost no longer use it, it is constantly fighting me.

When I log in, then I don't see the "Alerts Unread Posts Updated Topics..." bar. I have to press F5 to refresh. Sometimes that does not help. When I open a link in an other tab, then it is often gone again. I almost never know if I am logged in or not.

When I open a link to a topic (it can be any link from anywhere) then I often get kicked to forum.arduino.cc. Sometimes I have to try ten times in different ways to open a topic or a post in that topic. Sometimes I have to give up, because I can not open it.

I'm sure that when I disable all my security settings, ad-blockers, and whatever, that it will work. However, my security settings do not cause such problems on other sites. I have these problems only with this forum.

I'm sorry to hear you're having troubles Koepel. Things have been good for me lately with the forum but I recently switched to primarily using a fairly vanilla Chrome installation because I was just having such a bad time with my beloved Firefox + NoScript + etc. (though actually not so many issues with the Arduino forum).

Probably the best way to get the attention of the people who are able to investigate the situation is to submit a report via Arduino's contact form:
https://www.arduino.cc/en/contact-us
That will create a support ticket which will allow the issue (as well as any related reports from others) to be tracked and for Arduino employees to communicate with you about it.

Thanks!

Same here, on Win 10 Firefox and Chrome.

I have reduced a few blockers in Firefox and I have deleted all my cookies and other stored data from Google and from Arduino.cc.
Now I don't get kicked anymore 8)

The line "Alerts Unread Posts Updated Topics..." still does not show immediate after login in, but that is a minor problem.

Thx. I just got Firefox to work by turning off "Enhanced Tracking Protection" for https://forum.arduino.cc/

Pffft. Back to its old tricks. Sometimes can't login on Firefox, either.

My Firefox settings are:

  • block third-party cookies
  • trackers: block only in private windows.
  • whitelist cookie storing after closing Firefox for a arduino.cc (arduino.cc, login.arduino.cc, forum.arduino.cc).

I visit this forum in a normal window, not in a private window. So the trackers are enabled.

When I try to block cookies and visit the forum in private mode, then everything still works.
Maybe it is not the cookies. Maybe something that I turned off, but I forgot all the things that I have changed.

It seems to be a FF issue as I cannot even log in with FF even after doing a reset of the settings.
BUT when visiting individual sections I am signed in ?!?!?

I have contacted Arduino as pert wrote, and they wanted a video that shows how the problem. I was able to make a screenrecording that shows how I was kicked to https://forum.arduino.cc

After reducing my security settings and cleaning all cookies and website data, it did not happen anymore.
However, there is one single situation that still does it:

  • Log out and close Firefox.
  • Start Firefox
  • Goto forum.arduino.cc
  • Do not log in.
  • Move mouse over “Project Guidance”, and Firefox shows the correct link (with board=3.0).
  • Click it, and I get kicked back to https://forum.arduino.cc/

This happens also with “Microcontrollers”, but not with the other links.
When I click on the item of the “Last post”, then it does not happen (it did before).
I can fill in the URL bar the text: “https://forum.arduino.cc/index.php?board=3.0” and I also get kicked.
Turning off security settings and add-ons one by one was not enough to find the troublemaker. I guess it is some kind of combination.

I’m not familiar with the Firefox developer tools, and I can not find a difference between those two links and other links.

<a class="subject" href="https://forum.arduino.cc/index.php?board=3.0" id="b3">Project Guidance</a>

After doing those tests in my previous post, and after reducing more security settings, the situation got a lot worse.
When I am logged in, I can do one or two things, then I am no longer logged in. When I click on "Updated Topics" then I get kicked to https://forum.arduino.cc

At this moment the forum is almost not usable for me once again.

I opened at this forum this morning and was browsing and replying to posts without issue until I tried to use the search function in the page header to find one of my old posts. It did not find anything but using google it was the first hit. After using the arduino search bar I got logged out.

Hi Riva

Do you mean you were logged out on the SEARCH page ?
If you want to try that again BUT use the back button or jump directly to the forum are you still logged out ?

If you are still logged into the forum that is the "new normal" for the moment as AUTH0 broke the SSO.

ballscrewbob:
Do you mean you were logged out on the SEARCH page ?
If you want to try that again BUT use the back button or jump directly to the forum are you still logged out ?

If you are still logged into the forum that is the "new normal" for the moment as AUTH0 broke the SSO.

AFAIK I was not logged out on the search page but anything I search for comes back blank so I assume it must be linking to something external to arduino.cc and I'm blocking it.

Trying it today and it did not log me out but I will keep at it over the next few days as this morning I did not have to go through the ritual of clicking sign in (that goes nowhere) and page refresh to register I was actually still logged in.

Delete your browser cache.

I think that the website was changed and they asked me to delete the browser cache (or website storage or buffered data or whatever your browser calls it).
That solved a number of problems for me.

Koepel:
Delete your browser cache.

I use an incognito browser and every time I get fully logged out I close and reopen the browser so it always clears the cache and cookies.

DaveEvans:
Thx. I just got Firefox to work by turning off "Enhanced Tracking Protection" for https://forum.arduino.cc/

No legitimate website should be asking us to turn this setting off - it applies specifically to trackers that relay information after you leave the Arduino site.

I'm having similar problems as reported through this thread with both Chrome and Firefox. I'm currently unable to make any post on the forum. (Ironically, the post I'm trying to make is a security issue - where did the checksums go for Previous Version IDE downloads?)

No entity, even commercial ones, should expect us to allow this much tracking of our off-site web traffic without being called out on it. Clearly, there are too many scripts on this forum, which have the purpose of revenue rather than security, causing many problems for users of this site. I would like to see the Arduino team address this officially and publicly.

@gunship

IIRC the hash and such are still on github which is still the OFFICIAL repository of the IDE etc.

There are very few websites today that have NO TRACKING or some other form of user monitoring.
Always two parts to its usage and I also take issue with some parts often found on other sites which are more intrusive.

I might have given you karma for getting your post into the correct section but you missed out on getting up to date first in that the lifespan of this SMF forum is rapidly coming to a close so I withhold it.

gunship:
where did the checksums go for Previous Version IDE downloads?

Were there ever links for them? I just did a quick check on the Wayback Machine and there were none in 2019.

I think it would be nice to have, so that would be useful for you to make a feature request for that. The best way to do it is via the support form:
https://www.arduino.cc/en/contact-us
If you're unable to use that form with your preferred browser settings, another option is to submit an issue to this tracker:


As for your immediate needs, you can just hack the URL. You might notice that the IDE version is part of the checksums URL. So the current release's checksums are here:
https://downloads.arduino.cc/arduino-1.8.13.sha512sum.txt
and if you wanted 1.8.11, you only need to change the version number in the URL accordingly:
https://downloads.arduino.cc/arduino-1.8.11.sha512sum.txt

ballscrewbob:
IIRC the hash and such are still on github which is still the OFFICIAL repository of the IDE etc.

For the source code, yes, and even GPG signed archives as well:

but the built IDE is not available there. You can build it from that source if you like though:

@ballscrewbobThe hashes are not on github, that is the second place I looked.
Yes, tracking exists, but when it is breaking the functionality of the site enough that multiple users are struggling I believe that there is a problem that needs addressing - even if migrating to a new platform, awareness is beneficial so it doesn't happen again. And I will somehow survive without your award, thanks so much.

@pert The links were there only for a previous incarnation of the website when they first posted older version, never on the current page that I'm aware. Thank you for this workaround! I hadn't noticed they were still hosted, just not linked. I'll use this temporarily.

I will also request the feature, as my application is writing documentation for students that are using the previous versions and I'd prefer they be more readily visible on arduino's page.

Thank you @pert, you've been very helpful.