Type and Scope Errors on AdafruitIO_15_temp_humidity Example for Huzzah ESP8266

I downloaded what I thought was a legitimate sketch thru GITHUB. I’m using a HUZZAH ESP8266 with IDE 1.8.5. I believe that I’ve got the required up to date libraries

I’m getting about a half dozen type and scope errors that are resisting all of my efforts to correct the problem.

Attached please find the error file. Id appreciate all efforts to direct me towards a solution.

Thank you

Mike

huz_esp8266_error_020218.txt (13.1 KB)

Post a link to where you got the library from. Please use the chain links icon on the toolbar to make it clickable. Or if you installed it using Library Manger (Sketch > Include Library > Manage Libraries) then say so and state the full name of the library.

Here is a clickable link. Thanks for quick replay.

https://github.com/adafruit/Adafruit_IO_Arduino/blob/master/examples/adafruitio_15_temp_humidity/adafruitio_15_temp_humidity.ino

It works fine for me. I suspect the problem is that you have your sketchbook under OneDrive. You can see from this issue report: https://github.com/arduino/arduino-builder/issues/254 that causes problems unless you have a specific configuration of your OneDrive.

Thanks Pert!

You claimed to NOT be a windows guy. But...do you think I could get by with copying the entire Arduino folders to non One Drive folders then delete the One Drive folders that I might be able to run the example?

I've never "liked" One Drive and get tired of it fighting with my hard drives to store data.

Thanks

Mike

I actually am a Windows user and always have been but I've never been a Windows fanboy. I use it because that's the most common operating system and I feel that a developer can most effectively test when they are using the same environment as the users. However, with every new version of Windows I get more and more disgruntled. I just upgraded to Windows 10 and I think that may be the last straw. I'll use it until it's obsolete and then I'll probably be switching to Linux. I don't use OneDrive. It might be a useful feature but I don't really trust anything Microsoft. I just want the basic Windows OS, not all the bloat they force on you with it. I would like to have the option of installing things like OneDrive. Even though I have turned the feature off, I still have this special OneDrive folder that I can't delete. Even worse is this "3D Objects" folder. Ok, maybe that program is useful to some people but there's absolutely no reason for there to be some special Windows folder for it, just let people put their 3d objects in any folder they like! Just because 3d printing is the hype right now they had to screw up my file system.

OK, rant over.

You can set your sketchbook folder to any location you like in the Arduino IDE at File > Preferences > Sketchbook location. You can copy the contents of your current sketchbook folder to that location. It's unfortunate that the default location chosen by the Arduino IDE is in the OneDrive folder since there is this bug with Go and OneDrive and the errors it causes are not obviously caused by OneDrive.

I can't find a way to explicitly move files to One Drive or C: drive in order to compile the sketch. All of the example sketches seem to suffer from this problem.

I suspect that I'd have to either reformat a machine or buy a new machine then never use One Drive!

I've wasted a lot of time in the past couple of months and now I'm looking at spending sore $$$ on my "hobby from hell". Sheesh.

Thanks for the help Pert!

Have you tried just using Windows File Explorer to copy the contents of C:\Users\mlbra\OneDrive\Documents\Arduino to a new folder on your hard drive, not in OneDrive and then setting your sketchbook location to that new folder?

One question. Is there any chance that the work that you guys are talking about could "clean this mess up" or is any computer that has been exposed to One drive going to have problems. And by that I mean old library files, .ino and .c files will be "corrupted". In other words, any file that was processed through One Drive would have to be written, compiled and output otherwise?

Mike

Once the version of Go with the OneDrive fix is released, Arduino will switch to using that version and then the next release of the Arduino IDE after that will work with OneDrive. The Go release is scheduled for mid-2018 but it could be some time after that before the next Arduino IDE release. Likely there will be hourly or beta builds of the Arduino IDE available with the fix before the full Arduino IDE release if you don't mind using a potentially unstable version of the Arduino IDE.

There is also a workaround linked from that issue report: http://forum.arduino.cc/index.php?topic=509222.msg3485724#msg3485724 Apparently this causes OneDrive to lose its "Cloud" feature or whatever (I really don't know what OneDrive actually is) so that workaround may or may not be a usable option for you.

Yes. I tried both without success. I even tried copying files with type and source problems directly into folders with the example(s). No joy.

Mike

So you're saying that you have moved the sketchbook out of your OneDrive and the problem still occurs? If so, it's possible I am wrong about OneDrive being the cause of the problem.

Yes. The source file and supporting library files have been moved

There's nothing about having once been in OneDrive that will "pollute" your Arduino files. So this means I was on the wrong track and OneDrive was not the cause of the problem.

Please post the full contents of the config.h file that you are using with the adafruitio_15_temp_humidity sketch.

Pert
Here you go. config.h

config.h (1.73 KB)

OK, the problem is that you commented out lines 20 and 21 but then you forgot to uncomment either lines 31 and 32 or lines 42 and 43 (depending on whether you’re using FONA or Ethernet instead of WiFi).

BTW, if that IO_KEY value was supposed to be private information you should change it right away since it’s now public knowledge.

So ... why would your example(s) run while mine would fail?

Because I used the default config.h provided with the example. You modified your config.h but didn't tell me that. So we were compiling different code, and thus got different results.

So…why would your example run and mine won’t?

So… …here’s the code. It’s giving an unknown error. Any idea what’s going on here?

adafruitio_15_temp_humidity_Rev1.ino (2.39 KB)

020318_error.txt (5.36 KB)